Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Script-Fu

Members
  • Content Count

    78
  • Joined

  • Last visited

Posts posted by Script-Fu


  1. Where do you host now Andy? What kind of plan do you have compared to the siteground plan?

    Shared sometimes is not suitable because of its limitations imho - I would check SiteGround's either Terms of Service or Knowledgebase about resources used / when they shut you down so your understand when that could happen.

    ---

     I haven't used a hosting account like that in over 15 years. So i'm biased as we run an $70.00 a month Managed VPS with KnownHost since 2011. Then of course we can spin up what ever we need with DO.

    They KnownHost are a very good host imho. I was with Servint probably 6 years before that with yet another VPS. So we have been lucky.

    If it were me personally i would look into at least a reseller account with knownhost if your here in the States as they throw in cpanel in the cost. Plus you can see what resources you have at your disposal. 

    Btw i have no issues with siteground. They hosted a opensource project called impresscms that we worked on. Which we had no issues with at all.

     

     


  2. 3 hours ago, Havouza said:

    Last question then. On the old server I had redit installed and used it for cache. I have now inśtalled it also on this new one and checked if it works and all test are ok. But when I try to test the serber from the backoffice I get only red lines and it tells me to install the server again. I have also installed php-redis. What can be wrong?

    No log files nothing?


  3. @Havouza the redis server/module is out of my league. I have never heard of it. So i need to learn more.

    I'm sure someone else is better suited than me atm to answer your questions.

    However if you would link to the correct module you have installed into the back office.

    I'm sure someone else could help you. .


  4. My son was doing some mod-rewrite trickery and hacking the tools.php years back. I haven't needed better url's in a long time though. So he stopped messing with presta and starting working with the IBM WCS (WebSphere Commerce Suite). Heck he gave up drupal, xoops and impresscms. He rewrote all of impress pulling smarty out and hooking it up php template.

    Im not sure exactly what the op above is asking to do compared to the setup in tb & presta now. As i have been away for a number of years from all of this. I just remember him hooking me up with my url specific requests back in the day.

    I'll shut up now and go away! 


  5. You could rewrite them in the .htaccess file and be careful not to overwrite the file.


  6. This v1.2.5.1 module worked fine for me with out debug on this morning after i reinstalled TB 1.0.8.

    I had rolled my test site from TB 1.0.8 to bleeding edge before i tested this module yesterday. Then i rolled back to TB 1.0.8 so i figured i would i would start fresh this morning. With a new install of the 1.0.8 site

    Btw i tested this module this morning with PHP 5.6 & PHP 7.2 and like a said it works fine. Please take my little XML file for a test drive and see if it works.

    Anyway this morning the module would not choke with a valid XML file.

    <?xml version="1.0" encoding="UTF-8"?>
    <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
    xmlns:image="http://www.google.com/schemas/sitemap-image/1.1">
    <url ps_block="product">
    <image:image>
    <image:loc>{img_url}</image:loc>
    </image:image>
    </url>
    </urlset>

     

    Datakick is correct the developer didn't change much at all between the two modules according to the winmerge software package. 

    Sorry i didn't get back to you last night. After patching my roof in three spots. I started up my new to me riding mower. Which was powering thru 1 1/2 feet plus tall grass. Anyway i was riding up the back hill on the property and the mower decided to do a wheel stand and do a back flip onto me. lol I decided to call it a day at that point. This morning i don't have a scratch on me and feel fine.   


  7. Best thing to do is dump all the cache in this folder /themes/your_theme_name/cache manually

    Also clear /cache/smarty/cache & /cache/smarty/compile manually

    Then your browser cache and see if you still have error 500

     

    Best


  8. So i installed prestacenterxmlexportfree1241 AKA  v1.2.4.1 and fixed the only stopper issue i could find below. Sure the module has some other warnings. However they go by so fast i have no idea what they say. My thirtybees test site is running PHP 7.2

    [ThirtyBeesException]

    Call to a member function executeS() on boolean
    at line 77 in file modules/prestacenterxmlexportfree/classes/PcXmlFreeService.php

     

    72. 			->select('`'.self::$definition['primary'].'` id')
    73. 			->select('`name`')
    74. 			->from(self::$definition['table'])
    75. 			->orderBy('id')
    76. 			->build();
    77. 		return self::$db->executeS($sql);
    78. 	}
    79. 	public static function getFeedIds($ids)
    80. 	{
    81. 		if (empty($ids))
    82. 			return array();

    Replace line 77 with.

    return self::$db->executeSql;

    prestacenterxmlexportfree1241.zip

×