Error on back office product page



  • I tried to access the product page in the back office this morning and got this error:

    Fatal error: Uncaught Error: Access to undeclared static property: AdminProductsControllerCore::$cache_lang in /xxx/Store/controllers/admin/AdminProductsController.php:5234 Stack trace: #0 /xxx/Store/classes/helper/HelperList.php(263): AdminProductsControllerCore->displayPreviewLink(‘f090e4742c2e633…’, ‘1’, ‘Evolution Is St…’) #1 /xxx/Store/classes/helper/HelperList.php(177): HelperListCore->displayListContent() #2 /xxx/Store/classes/controller/AdminController.php(3154): HelperListCore->generateList(Array, Array) #3 /xxx/Store/controllers/admin/AdminProductsController.php(2613): AdminControllerCore->renderList() #4 /xxx/Store/classes/controller/AdminController.php(2429): AdminProductsControllerCore->renderList() #5 /xxx/Store/controllers/admin/AdminProductsController.php(2531): in xxx/Store/controllers/admin/AdminProductsController.php on line 5234

    I have not done anything with the AdminProductsController.php or anything with products at all in the last few days. I have been trying to figure out the login problem with PayPal and Amazon.

    Thank you for any insights into this problem.



  • I found the cause of the problem. It was the patch for the back end security. I replaced the AdminController.php file with the old one and I could open the page that was throwing the above error.



  • I’m so relieved that this didn’t happen to me because all the weird, unanswerable issues usually find me. 🙂



  • @mdekker I didn’t replace the other file in the patch with the old one. Should I, or should I just leave it and hope that 1.01 is released soon?



  • Thanks 🙂



  • I applied the new patch and got the same error on the back office product page. So replaced the AdminController.php file with the old one again 😞



  • I reapplied the patch, cleared the OPCache and all other caches, restarted the php and got the same error.



  • I downloaded the new patch file if that is what you mean. I will try the whole process again. I checked the file I uploaded and found public static $cacheLang = []; on line 48.



  • That fixed it. Thank you!



  • I just applied the patch. Thanks @jnsgioia @mdekker


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.