category page non accessible



  • I have enabled ssl on my site .
    Everything works except the category page
    https://www.abc.com/?controller=category&id_category=3

    When the friendly url is on
    it says 404 not found
    when it is switched off
    it redirects to non ssl link
    http://www.abc.com/?controller=category&id_category=3
    and says too many redirects

    As far as i know i don’t think their is a problem with seo settings or .htaccess
    seems like ssl might be configured wrong

    Plz help me
    In an environment without ssl everything works normal.


  • Global Moderator

    Moved this to the bug reports section as it’s obviously a bug report.



  • can you share your web server ssl block?


  • Global Moderator

    Opened a Github issue for this, too: https://github.com/thirtybees/thirtybees/issues/394

    As moving a post apparently leaves no trail in the original spot behind: ping @Saha :-)



  • @yaniv14
    <IfModule mod_ssl.c>
    <VirtualHost default:443>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    
            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf
    
    
            #   SSL Engine Switch:
            #   Enable/Disable SSL for this virtual host.
            SSLEngine on
    
            #   A self-signed (snakeoil) certificate can be created by installing
            #   the ssl-cert package. See
            #   /usr/share/doc/apache2/README.Debian.gz for more info.
            #   If both key and certificate are stored in the same file, only the
            #   SSLCertificateFile directive is needed.
            SSLCertificateFile      /etc/ssl/certs/ssl-cert-secret.pem
            SSLCertificateKeyFile /etc/ssl/private/secret.key
    

    <FilesMatch “.(cgi|shtml|phtml|php)$”>
    SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory /usr/lib/cgi-bin>
    SSLOptions +StdEnvVars
    </Directory>
    </VirtualHost>
    </IfModule>



  • It’s been a long time still not able to resolve this issue.
    Need some urgent Help can somebody please help me.



  • @saha said in category page non accessible:

    Need some urgent Help can somebody please help me.

    Have you got access to webserver’ logs?
    How you configured your system, i.e. which webserver version, php version, mysql, et c.?

    I asking, because had similar problems, caused by more than one version of php were installed on my server.

    UPD 1: Have you thought about nginx web-server? As for me its configs are much more clear and easy to understand.



  • I have apache server
    apache2 version : 2.4.25
    build : 2017-07-27T14:32:31
    php version : PHP 7.0.22-0ubuntu0.17.04.1

    mysql : mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

    I only have one php version installed



  • @saha
    Any logfiles? Error messages in it?

    As for php i would recommend to run following command:

    $ sudo update-alternatives --list phar
    $ sudo update-alternatives --list php
    

    Just to be sure, that all links are set to php 7.0



  • @daokakao
    Did not help having the same issue.
    Does Thirty bee have canonical redirection issue with ssl ?
    In the admin section Preference->seo
    Redirect to the canonical URL if i set this no redirection
    The category page works Displaying the link in non url friendly format
    like http://abc.com/?controller=category&id_category=3



  • Well, since i dont use apache, i can just advice few common steps to find the issue cause:

    1. Check the logfiles. This should be very first thing you do in case of any issue (s)
    2. Check webserver’ and php’ config files - oftenly it is root of most issues, especially when there’re no similar questions described in the internet
    3. Only if no result, it is highly probable the root of issue is software bug.

Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.