Disable confirmation e-mail when creating an order in back office.



  • Is it possible? To disable the confirmation e-mail that is send when creating an order in back office.



  • Upon further investigation I can see that the content of the e-mail is determined by the status of the order. I thought the confirmation e-mail was sent as automatic standard. I can’t understand why you cannot disable the e-mail, though. Shouldn’t that be possible in the status?

    99% of my orders are made by me in back-end, so it’s quite important to me.



  • you could always delete the associated email in mails/en(or whatever language you’re using). That may create in error, I’m not sure, but may work for ya.

    edit: there has to be a better solution than that. As your customers when they do create an order, wont get those emails.



  • @b_otho

    have you tried to change the status

    0_1514483943991_71ae3323-4d54-4224-9e60-0e9523b89cd5-grafik.png



  • @zimmer-media

    I’m not quite sure what you mean? To use a different status? Or to make my own status? I’ve tried both, it doesn’t seem to make a difference.



  • goto BO>Orders>Statuses and unclick the, Send email to customer, for the ones you want to not send



  • @SLiCK_303

    It is not enabled.



  • I don’t think it can be done, without some override of the core files or something. Sending out the order_conf mail is a built in sorta thing…



  • Solved! @SLiCK_303 you’re right, though it needs to be done through an override of PaymentModule.php.

    Delete/uncomment the following, and you are able to control if a mail is sent or not through the status:

    if (Validate::isEmail($this->context->customer->email)) {
    Mail::Send(
    (int) $order->id_lang,
    ‘order_conf’,
    Mail::l(‘Order confirmation’, (int) $order->id_lang),
    $data,
    $this->context->customer->email,
    $this->context->customer->firstname.’ '.$this->context->customer->lastname,
    null,
    null,
    $fileAttachment,
    null,
    PS_MAIL_DIR,
    false,
    (int) $order->id_shop
    );
    }



  • well done


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.