Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Saha

Elastic Search CORS Error [SOLVED]

Recommended Posts

Failed to load http://localhost:9200/thirtybees11/_search: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://thirtybee.local' is therefore not allowed access.

Share this post


Link to post
Share on other sites

Are you using the domain thirtybees.local? Or is that something we left in the module?

Share this post


Link to post
Share on other sites

It sounds like then you need to set the cors policy of your local instance to be able to connect to your elastic instance. https://enable-cors.org/server_apache.html

Share this post


Link to post
Share on other sites

@lesley I did try this . Put the code in apache conf,virtual host as well as .htaccess still no luck .

Share this post


Link to post
Share on other sites

I am not positive, but it might require a domain name being attached and then adding a content policy for the domain.

Share this post


Link to post
Share on other sites

It looks like you are using localhost for your elastic instance, it might require you to use a domain name instead of a local host. @mdekker might be best suited to answer this one.

Share this post


Link to post
Share on other sites

@lesley You mean it will work fine on domain and not on local host. Thankyou.

Share this post


Link to post
Share on other sites

I think lesley is right.

The issue here is you need to run it thrue Apache or Nginx in proxy, and make sure the config for that proxy has the right headers set for Access-Control-Allow-Origin.

Apache Header set Access-Control-Allow-Origin "*"

Nginx add_header 'Access-Control-Allow-Origin' '*';

Share this post


Link to post
Share on other sites

Actually found some more info, it looks like in the configuration of Elasticsearch you can setup CORS to there is some more info about it on https://github.com/elastic/elasticsearch/issues/9031

Share this post


Link to post
Share on other sites

Setting http.cors.enabled : true http.cors.allow-origin : "*" In Elastic config located at config/elasticsearch.yml Fixed the Issue. But Now i am getting { "error":{ "root_cause":[ { "type":"illegal_argument_exception", "reason":"query malformed, empty clause found at [1:533]" } ], "type":"illegal_argument_exception", "reason":"query malformed, empty clause found at [1:533]" }, "status":400 }

Share this post


Link to post
Share on other sites

Hmm revert back to the settings before you change, i think it's better to proxy it via nginx since Elastic Search can be a bit of a PITA.

Share this post


Link to post
Share on other sites

{ “error”:{ “rootcause”:[ { “type”:“illegalargumentexception”, “reason”:“query malformed, empty clause found at [1:533]” } ], “type”:“illegalargument_exception”, “reason”:“query malformed, empty clause found at [1:533]” }, “status”:400 } @lesley @mdekker Anyone

Share this post


Link to post
Share on other sites

hmm in the elastic search module is the query missing there something sounds like it in my mind.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...