Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

datakick

[Free Module]Revws - Product Reviews

Recommended Posts

@datakick Is it in the roadmap of the premium version to allow upload videos in addition to images? I think it does not exist this option in any other PS/TB reviews module and it is very useful as Amazon has proved to make reviews of the products by the users themselves

Share this post


Link to post
Share on other sites

If you want the rating to appear below the product title, just edit the product.tpl file.

Find this line #239:  <h1 itemprop="name">{$product->name|escape:'html':'UTF-8'}</h1>

Then add this hook after:

{hook h='displayRevwsAverageRating' mod='revws'}

 

Share this post


Link to post
Share on other sites

Hi,

I don't see if this issue has been reported before but has anyone noticed the text on the bottom of the emails (footer) that customers receive when asked to submit a review? Part of the text says this: "Revws - your datakick review module". The word 'datakick' is clickable and when clicked, the link takes customers to the getdatakick.com website and I'm not sure why it needs to be there??? Is it a legal requirement, considering the module is free or can it be easily removed without any issues?

Share this post


Link to post
Share on other sites
17 minutes ago, Mike1 said:

Hi,

I don't see if this issue has been reported before but has anyone noticed the text on the bottom of the emails (footer) that customers receive when asked to submit a review? Part of the text says this: "Revws - your datakick review module". The word 'datakick' is clickable and when clicked, the link takes customers to the getdatakick.com website and I'm not sure why it needs to be there??? Is it a legal requirement, considering the module is free or can it be easily removed without any issues?

Feel free to modify the email template to whatever you need. 

  • Like 1

Share this post


Link to post
Share on other sites

Has anyone also the Smiley Problem? A lot of our customer use smileys on their review and the module seems to output it as "?"...

@datakick is there any easy solution for this?

Share this post


Link to post
Share on other sites
3 hours ago, wakabayashi said:

Has anyone also the Smiley Problem? A lot of our customer use smileys on their review and the module seems to output it as "?"...

@datakick is there any easy solution for this?

Ou, revws tables use utf8 charset, that's not suitable for storing emoji. I might fix this in the future. Meanwhile, you can modify the tables 

https://stackoverflow.com/questions/39463134/how-to-store-emoji-character-in-mysql-database

Share this post


Link to post
Share on other sites

Hi

I'm on my 2nd website and was trying to uninstall the recent reviews but getting this error message

I tried clearing cache

Call to undefined method RevwsRecent::clearCache()
in file modules/revwsrecent/revwsrecent.php at line 48
Source file: modules/revwsrecent/revwsrecent.php

29:        $this->bootstrap = true;
30:        parent::__construct();
31:
32:        $this->displayName = $this->l('Recent reviews');
33:        $this->description = $this->l('Displays recent revws reviews on your homepage.');
34:    	$this->ps_versions_compliancy = array('min' => '1.6', 'max' => _PS_VERSION_);
35:        $this->tb_versions_compliancy = '> 1.0.0';
36:    }
37:
38:    public function install() {
39:        if (!parent::install()) {
40:            return false;
41:        }
42:        $this->registerHook('displayHomeTab');
43:        $this->registerHook('displayHomeTabContent');
44:        return true;
45:    }
46:
47:    public function uninstall() {
48:        $this->clearCache();
49:        return parent::uninstall();
50:    }
51:
52:    public function hookDisplayHomeTab() {
53:        return $this->display(__FILE__, 'tab.tpl');
54:    }
55:
56:    public function hookDisplayHomeTabContent() {
57:        return $this->display(__FILE__, 'content.tpl');
58:    }

 

Share this post


Link to post
Share on other sites
11 hours ago, AndyC said:

Hi

I'm on my 2nd website and was trying to uninstall the recent reviews but getting this error message

 

Thanks for reporting this issue. This is my fault - I've copied / pasted the uninstall method from my other module, and it does not work in this one.

Anyway, the fix is very simple -- delete the uninstall method completely (lines 47-50). And then try to uninstall again.

Share this post


Link to post
Share on other sites

Hi

Thank you .. I got caught out by a simple } lol.. I just deleted lines 47 - 50 Think the } was on line 45 which caused a 500 page .. But once I looked again I saw the double

} 

}

Once I deleted 1 it worked fine after

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I've also noticed the reviews doesn't work in tabs anymore when viewing any product. It just adds a review button on the bottom.

Could someone using toplakd modded theme confirm this please , in case it is just me

Share this post


Link to post
Share on other sites
15 minutes ago, AndyC said:

I've also noticed the reviews doesn't work in tabs anymore when viewing any product. It just adds a review button on the bottom.

Could someone using toplakd modded theme confirm this please , in case it is just me

That's theme responsibility. Some themes render tabs as a normal sections with headers

  • Like 1

Share this post


Link to post
Share on other sites

Thank you.. It@ fine underneath by using mods other option. I did wonder that as it was fine on the old original theme pre niara

Share this post


Link to post
Share on other sites
14 hours ago, AndyC said:

I've also noticed the reviews doesn't work in tabs anymore when viewing any product.

Can you explain little more. Or show some pics.

As I just installed it, and I see it exactly same on Niara / Community default and modded one

Share this post


Link to post
Share on other sites
Posted (edited)

 Sure  No Problem ..Here are both views tab then block view

tab.JPG

sep.JPG

Edited by AndyC

Share this post


Link to post
Share on other sites

Sorry, can't find option to select view as tabs on product page.

  • Thanks 1

Share this post


Link to post
Share on other sites

My suggestion is, that you try to use the product.tpl from old version of community-theme-default.

As only thing modded in product.tpl (from bleeding edge community-default) was on line 692 rows="3" to rows="1" and that is not affecting your tab view.

Share this post


Link to post
Share on other sites

Neither community theme, nor niara theme, supports tabs on product page. It's not hard to do, but I guess the theme author liked all-in-page better then tabbed content

  • Like 1

Share this post


Link to post
Share on other sites

Going though my logs I found this error ,anything to worry about

*ERROR* 	2020/06/25 - 20:44:56: RecursiveDirectoryIterator::__construct(/home/myusername/domains/website.co.uk/public_html/cache/smarty/cache/revws/1/17/863/24/25): failed to open dir: No such file or directory at line 67 in file vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_cacheresourcefile.php

 

Share this post


Link to post
Share on other sites
9 hours ago, AndyC said:

Going though my logs I found this error ,anything to worry about


*ERROR* 	2020/06/25 - 20:44:56: RecursiveDirectoryIterator::__construct(/home/myusername/domains/website.co.uk/public_html/cache/smarty/cache/revws/1/17/863/24/25): failed to open dir: No such file or directory at line 67 in file vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_cacheresourcefile.php

 

This has nothing to do with the module. Looks like you have some permission issues with your smarty cache directories. To fix this, delete content of /cache/smarty/cache and /cache/smarty/compile directories

  • Thanks 1

Share this post


Link to post
Share on other sites

Sorry another weird issue

It's the 3rd 1 I have seen where revws URL brings up  Error Permission denied page, does thsi link make any sense

https://www.mywebsite.co.uk/module/revws/EmailAction?id=43&action=efivfj&product-id=142&rating=3&secret=92748d03aafbbdce2e738aa6e99b9c3a

I've just made a test purchase and all went as it should with being signed into my account and not signed in

Share this post


Link to post
Share on other sites
16 minutes ago, AndyC said:

Sorry another weird issue

It's the 3rd 1 I have seen where revws URL brings up  Error Permission denied page, does thsi link make any sense


https://www.mywebsite.co.uk/module/revws/EmailAction?id=43&action=efivfj&product-id=142&rating=3&secret=92748d03aafbbdce2e738aa6e99b9c3a

I've just made a test purchase and all went as it should with being signed into my account and not signed in

action=efivfj in the url is definitely not correct.

Share this post


Link to post
Share on other sites

I thought it may be un-subscribe , but I see it says unsubscribe&secret in the link so it isn't that. Any ideas as to how this could happen

Share this post


Link to post
Share on other sites
8 minutes ago, AndyC said:

I thought it may be un-subscribe , but I see it says unsubscribe&secret in the link so it isn't that. Any ideas as to how this could happen

I'm sorry, I don't really understand. How what could happen? Does email sent from your store contains link with action=efivfj  instead of action=review? If that's the case, then there needs to be some module / override / modification that modifies this during mail send. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...