Video in FO without controllers.



  • Hello Folks,
    I tried to fix the follow prob:
    When I implement a video on the Product page, in the FO they showing without controllers to let them start.
    The controllers come up, when I right click on the video and activate the controllers. Have someone some solution to this?

    2_1518188613836_Video bestand regelaars niet zichtbaar.png 1_1518188613836_Video bestand FO zonder regelaars.png 0_1518188613834_Video bestand FO.png



  • Sorry I dont get, what you are talking about. What kind of video player is this?



  • Hmm, I add the source in BO, inserting a video and the code are:

    1_1518189222636_Video source code1.png 0_1518189222635_Video source code.png



  • Oh I am not sure about that. Probably this is just using the html video player inbuilt by the browser you use. So the behaviour will be different between browsers…



  • Try:

    <video width="300" height="150" controls>
      <source src="........." type="video/mp4">
    </video>
    

    These are available attributes for video tag:

    autoplay	- Specifies that the video will start playing as soon as it is ready
    
    controls	- Specifies that video controls should be displayed (such as a play/pause button etc).
    
    height (pixels) - Sets the height of the video player
    
    loop - Specifies that the video will start over again, every time it is finished
    
    muted - Specifies that the audio output of the video should be muted
    
    poster - URL Specifies an image to be shown while the video is downloading, or until the user hits the play button
    
    width (pixels) - Sets the width of the video player
    


  • Thanks, the controller did the trick.
    And now the follow, I want to set the video outlining to the middle on the page, but when I save the settings, they go back to left.
    The margin settings stay in the source, but without any effect.

    <video width=“300” height=“150” style=“margin-left:auto;margin-right:auto;” controls=“controls”><source src=“ ” type=“video/mp4” /></video>

    BTW, can we fix the controller settings in a script, so we don’t do this on every video manually?



  • Try adding display: block;



  • Hello yaniv14,
    Thnx for the suggestion, but it makes no effect.


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.