Unable to edit or modify categories since migration



  • After three days of painful transfers, I have finally managed to get my shop somewhat back on its feet following a migration that is not easy by any stretch of the imagination. I have had help from Petr from Datakick and he has eased the process somewhat.

    Now I cannot modify anything in Categories. The only way for me to do anything there is to go inside the Database and edit it there. Nothing works on the backend. I get the following errors:

    Failed to update the Status

    or

    An error occurred while updating an object. category ()

    Any idea how to fix this?

    Also having vexing problems with the file manager calling scripts through http instead of https, basically rendering the search engine unusable as everything gets blocked by the browser. It used to work fine under PS.

    Several modules worked when I did my test site but ever since I have uploaded my backup from the database, a few of them have ceased working. Also, some functionalities of TB have disappeared such as the possibility to put custom codes or the duplicate content checker. Any ideas why?

    Thanks!!!


  • administrators

    It sounds like you merged a PrestaShop and thirty bees shop, not migrated it.



  • Using the migration module did not work properly (PS 1.6.17). Most of the modules did not work, theme was broken.

    What I did is do a clean install of TB, reinstalled the theme from TB, installed all modules from TB, then imported the PS database into the TB database.

    That is the only thing that led to my site looking remotely like it used to be. But there are a few issues with some modules, the categories problem and some functions suddenly missing from TB.

    Why would that cause issues if the core files are more or less similar?


  • administrators

    Because the databases have changes.



  • AAAAAARGH!


  • administrators

    I would check the error logs on your server to see what errors are being picked up on the page loads / saves, that is likely the best way to solve the issue.



  • Will do. Thanks for the pointers.



  • I went back to an older backup and reinstall everything. When I try to upgrade using the TB migration tool, I get this error when updating the database: Error [Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

    The PHP error log gives me the following error: PHP Fatal error: Class ‘CryptBlowfish’ not found in /home/public_html/classes/

    However, mcrypt is installed and enabled…

    The end result is that the database does not install properly. In some cases, I get a 500 error and can no longer log in.



  • This is what the preferences menus look like in tb. Just make yours look the same… Goto BO>Administration>Menus, then add the couple you dont have (Duplicate URLs, and Source Code) . Click on the add new button, next to the refresh button on the topish right. Then in Name type in Source Code, then in class, type in AdminCustomCode. Do the duplicate URLs the same way, looking at my image here.
    0_1518536127017_Capture.PNG

    Here is Duplicate URLs for example…
    0_1518536618694_Capture.PNG



  • Thank you! One more step fixed. Really appreciated.



  • No problem. I hope you get your overrides working…



  • @slick_303 Made some strides today on that front with the help of @datakick. Almost out of the woods, only a handful of modules still not working properly now. Almost back to where I was with speed as a bonus!



  • Very nice, keep up the good work, you’ll get there.



  • @slick_303 I appreciate the help and support. This is a great community. Quite a nice change of pace!


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.