Auto-update to newest version is working again



  • Working as intended on my test, good job.



  • Awesome! I’ll use it for the next release



  • @datakick I have had that disagreement (re: shared hosting) happen to me several times already. Unfortunately, for most shops, if you want some level of freedom, a dedicated host or at least a VPS is necessary nowadays. Big learning curve but I would never go back!

    Thanks for all the hard work fixing the updater guys!!!



  • 1.03 to 1.06 worked flawlessly and quickly! Brilliant job!



  • I took a fresh 1.01 install and upgraded it to 1.06. I compared the result to a fresh 1.06 install. Not every difference may be significant but I hope the overview of the differences is helpful in fixing things. Note that I took fresh installs. I didn’t even look at the front:

    The results of comparing files:

    • translations (both nl.php files and files under \translations) are not updated. Maybe this should become an option?
    • It looks like nothing under the \vendor directory is updated. Changed were ezyang, greenlion,guzzlehttp,jakeasmith,mrclay,pear and swiftmailed. Geoip had disappeared in the fresh 1.06.
    • I had indicated that the theme should be updated. However, its Modules, Css and Sass subdirectories seem not changed. This also happened to gulpfile.js and package.json. 1.01 had a Stylesheets subdirectory that has disappeared in 1.06. The Tools subdirectory contains three javascript files in 1.06 and one in the updated 1.01.
      In the root advanced-payment-api.js is missing in the updated 1.01.
    • the mails directory is not updated. Again: should this be optional?
    • nothing in the config directory is replaced
    • the .sass files of the admin theme are not replaced

    The modules directory:

    • Nine not installed modules have all files in the updated 1.01 and only a translations directory in 1.06
    • many new modules cannot be found in the updated 1.01. The fresh 1.06 Modules directory has 87 subdirectories. The updated 1.01 only 54. Fixerio is the only modules that was present in the updated 1.01 and not in the fresh 1.06.

    The updated 1.01 offers mails in all languages. 1.06 only in those installed.

    The result of comparing database structures:

    • On quite a few places 1.06 has default dates of “1970-01-01” where the upgraded 1.01 has “0000-00-00”
    • On quite a few fields 1.06 has field length 11 where the upgraded 1.01 has 10.
    • some of the upgraded 1.01 tables have charset utf8 while 1.06 has utf8mb4 everywhere
    • the table with the most differences is tb_page_cache. The upgraded 1.01 has much more keys. See <a href=“https://www.prestools.com/updiff.jpg”>image</a>.

    In the configuration table:

    • PS_VERSION_DB is 1.6.1.999 in the upgraded 1.01 and 1.06 in the fresh 1.06
    • PS_SHIPPING_HANDLING is 2 in the upgraded 1.01 and 0 in 1.06
    • PS_STATS_RENDER’, ‘statsmodule’ in 1.06 and graphnvd3 in upgraded 1.01
    • PS_STATS_GRID_RENDER ‘statsmodule’ in 1.06 and gridhtml in upgraded 1.01
    • The 1.06 configuration table has 11 more entries. Examples that are found in 1.06 and not in the updated 1.01 are BLOCKSOCIAL_AMAZON and TB_USE_WEBP


  • Big thank you for this list, @musicmaster!



  • On top of my wishlist for any upgrader module is to be forced to make a choice whether I want a backup or not. Too often I find myself clicking Upgrade and backupping while I really don’t want. And then I have to wait forever… Making no backup the default is not really an option. But you can force the user to make an explicit choice and if he forgets to do so give him a popup “please choose your backup option”.

    It is rather simple to implement and I can have a look at it when find some time. But what do other people think about this modification?



  • The new upgrader will be just as fast with a backup as without one. Magic? Nope. KISS.



  • I honestly think the yes / no button is enough. If we start making pop up alerts to ask people things where do we stop? If they are not paying attention when doing a process it is not our fault, why annoy the people who are.



  • @musicmaster
    What an excellent post! Thank you for that thorough check!
    Hopefully all these issues will be fixed shortly.



  • Since updating to 1.0.6 from 1.0.3 using updater with Panda I’ve lost dashboard online visitors

    When I click online visitors I get "no module installed"
    Which module?

    I have google analytics and Data Mining for Statistics installed with save page views for each customer enabled same as before update.

    It worked before update.
    All others stats are working except visitors.

    Thanks!

    0_1536951855746_Screen Shot 2018-09-14 at 2.47.50 PM.png



  • Same here!



  • Can you all try installing the stats module.



  • @lesley forgot to mention I tried the stats module too
    Brings me to a blank page showing my old ico so I guess out of TB



  • @lesley said in Auto-update to newest version is working again:

    Can you all try installing the stats module.

    It gives me an HTTP 500 error, but other pages work fine.



  • Update to online visitors not working…

    Just installed Statistics Module v2.0.1 - by thirty bees again with intent to “reset” to see if that would make a difference since it didn’t work last time I installed it, it brought me to a blank page.

    And just like that dashboard online visitors is now working again…without using reset. Hm…

    Not sure why it didn’t work last time and if there were any changes in the background but now it does show visitors after using updater from 1.0.3 to 1.0.6 with Panda theme

    @30knees maybe try again!



  • Nope, I uninstalled, reinstalled, reset - still the same error message I reported to @lesley.



  • Oh, what is the error message you are seeing?



  • HTTP 500 after clicking on “online visitors”



  • Turn on debug mode and see what error you are getting.


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.