Back to PrestaShop or stay with Thirty Bees ?



  • I’m migrating an old PrestaShop 1.4.6 to Thirty Bees 1.07

    Everything goes fine, but looking at Themes there isn’t much choice 😞

    • The Transformer Theme isn’t Thirty Bees compatible ( that’s what the developer told me by mail )
    • The Panda Theme is only compatible for TB 1.03 ( also told by developer, and he’s in doubt whether
      to update the Panda Theme to TB 1.07 while he has only a few interested customers for TB 1.07 )
    • Warehouse Theme : there’s no separate edition for TB, but should work fine with maybe a few modifications

    i also found https://www.datanyze.com/market-share/e-commerce-platforms/prestashop-vs-thirty-bees/
    As i can see, there are 151 TB shops in use now versus 99.616 PrestaShops.

    From mail conversation with developers from Themes / modules : they think that the future for TB might be uncertain and that the newest version from PS is much better than the start versions of the 1.7 version.

    My customer choice was for first instance Thirty Bees, but after searching for Themes, and the datanyze page which shows there are only 151 shops live makes him doubt much for the future.

    For myself : as i look at the many(!) bug fixes between each PrestaShop versions, i wonder how many bugs there still are…
    From the PS 1.6 version i know it is stable, and i know TB is based on the PS 1.6 version.

    Who can tell me there experience and convince my customer to stay with TB, or leave and go to PS ?



  • This post is deleted!


  • I just released an update of panda theme v1 for TB 1.0.7. @cdwebman you’ve contacted me personally, I can sense you prefer TB, so if you are still interested in panda theme v1 for TB, then take a look.
    @lesley I am still working on improving my themes and answer support questions, check my website I am there every day. I never received any messages from you in last few months, I guess one of our support team members might have seen your emails but they didn’t let me know, sorry for that.



  • This post is deleted!


  • That’s awesome @Jonny. Can I ask what needed to be done to make your theme compatible with tb 1.0.7? I’m interested because there shouldn’t be any changes necessary, in theory 🙂 If there’s some breaking change between tb1.0.3 and tb1.0.7 we’d love to know, so we could fix it



  • Nice… Good news🎉 I will consider to buy transformer or/and panda theme for my second store 🙂



  • I just released an update of panda theme v1 for TB 1.0.7.

    That’s great news!

    And I join @datakick in being curious on which changes were needed.



  • It’s a shame Warehouse developer doesn’t support TB



  • @jonny said in Back to PrestaShop or stay with Thirty Bees ?:

    I just released an update of panda theme v1 for TB 1.0.7. @cdwebman you’ve contacted me personally, I can sense you prefer TB, so if you are still interested in panda theme v1 for TB, then take a look.

    That’s great! And it looks like all that is needed to update is to upload the update v1.4.2.zip to the panda theme folder on the server. Is this correct?



  • @cdwebman Here’s my thoughts about your original question.

    First, let me say that I too think ps17 platform is getting better and better. As a developer, I really like what they are doing there, the system architecture is shaping nicely. It’s becoming easier to develop modules and themes for that platform. Some things that are really hard or impossible to do in ps16/tb can be done quite easily there.

    But the only reason why this is happening is thanks to Prestashop’s decision to break compatibility. And this is the biggest issue I have with them. They screwed hundreds of thousands of their own customers running on ps16 - most modules merchants already bought for ps16 will not work on ps17, so they will need to purchase a new ones. There is also no automated upgrade system from ps16 to ps17, so it requires paid service to even stay updated. They also screwed module and theme developers – sales of ps16 modules dropped significantly as merchants don’t wants to invest into dying platform. Developers are forced to re-implement their modules for ps17 platform, which can take huge amount of resources. Note that it may take years for module to break even, or become profitable. That’s one of the reasons why so many third party developers are jumping ships lately.

    The only one who benefits from this decision is Prestashop itself – they will have better platform, and influx of sales from ps17 modules. They don’t care that everyone else got hurt.

    I believe everyone needs some stability, both merchants and developers. And I don’t trust ps17 platform on this point. Thirtybees, on the other hand, has backwards compatibility as one of their core pillars. And I hope it will remain the same, even with thirtybees 2.0



  • What a difference from xenforo 1.5 to 2.0!

    1.X addons obviously not working in 2.X… but if you upgrade the core from 1.5 to 2.x the data of the 1.X addons is still there (and the addons get deactivated), if you install a 2.0 compatible addon it will find the old data and convert it to the new “format”. Plus many developers simply updated their addons and if you have an active license with them you get the 2.x version of the addon.



  • @lesley instead of spewing your diatribe i think it would be better to give the community a short update once in a while about the project. Uncertainty is bad for the project.



  • There’s a oriental saying: “A dog is barkin’, a caravan goes however”. @lesley, @mdekker , @Traumflug, @datakick, @yaniv14 and others - you doin’ a great job, so please dont pay much attention for such barks, just keep movin’ your caravan 😉



  • @vincentdenkspel I did not realize the community needed reassuring again. We are making stable builds about every 40 days now, we are at all time traffic levels to our site, all time high daily installation levels of thirty bees, we have lots of new modules added to our store, ect. Things have started picking up and are going really well here, I thought it was kind of obvious. Sorry about that. As a side note on a different topic, I am planning on adding your shop to our shops using thirty bees section likely tomorrow.



  • what I find interesting is why woocomerce is no1. Maybe I mssing something but setting up an eshop on top of an blog platform seems strange to me. Last time I tried that with joomla/virtuemart I found it was a big mess.
    @cdwebman themes is the easiest thing to fix if you are willing to pay, This community has proven that it will do everything it can to support it’s users even for free. Sure I find thing in tb that I don’t like but this does not mean that it has no future. I am really glad that @lesley says tb is starting to make money. This project is a marathon not a sprint.



  • @cdwebman well, it’s up to your customer and his willingness to act against his own interest. I switched to TB because of one single module not able to work under PS1.7 and because their API was literally keeping me stopped while the back office was stuck. In those circumstances, it is totally useless if PS has 100k users or ten million. Themes/modules developers opinion is just this, an opinion. Users are who really decide. If they face massive modules deprecation under PS1.7 or a chance to keep them running under TB I think the decision will be very clear.

    I predict that when PS stops supporting 1.6 after this last minute, surprise support extension until next May, store owners will be willing to pay for a migration to TB.



  • @lesley said in Back to PrestaShop or stay with Thirty Bees ?:

    @vincentdenkspel I did not realize the community needed reassuring again. We are making stable builds about every 40 days now, we are at all time traffic levels to our site, all time high daily installation levels of thirty bees, we have lots of new modules added to our store, ect. Things have started picking up and are going really well here, I thought it was kind of obvious. Sorry about that. As a side note on a different topic, I am planning on adding your shop to our shops using thirty bees section likely tomorrow.

    Well its much better now with the updates once a month 🙂 keeps the hope alive
    just hope @mdekker comes back soon 🙂



  • @cprats A lot already are, that is what is powering a lot of sales in our store.



  • Hé, this forum is alive, and it looks like TB is also very alive ! 🙂 🙂

    This gives me faith in Thirty Bees, also good to read that the Panda Theme has released a new version for TB 1.07
    I contacted Johnny personally, he always gives me a quick reply !
    Maybe my mails and this forum post also convinced him to quickly released the new version of the Panda Theme for 1.07…

    It’s a pity that there are so less Themes available for TB at this moment, more developers have to be convinced about TB !
    I really don’t understand that developpers don’t see TB as a big opportunity to make money with Themes for TB,
    especially while TB is growing and not many developpers aim at TB at this moment.

    I also have good experience with the people from Presteamshop.com who helped me with a module from them which had a little problem with TB,
    but they helped me quickly, I noticed them also at the possibility to sell theirs module at TB.

    @Lesley : you wrote : "Especially when you consider an upstart fork of PrestaShop has almost 30k shops using their software"
    Does this means that TB is being used already for 30K shops ?
    Maybe i was misleaded by the url from datanyze which shows that only 150 shops are using TB, as you understand this causes the doubts at my customers side

    And i do understand that you hate post like these, but as far is i look now this post turns now into a really positive post !

    For myself i have faith in TB, now i will have to wait what my customer thinks about this post, and what he decides…

    Thanks all for yours reply, whatever my customer decides, i will use TB for new shops !



  • @nickon
    I think Woocomerce is no.1 because it works with Wordpress, and there are so many people using wordpress sites.
    I really do not like anything about Wordpress : too many hackers try to mis-use wordpress sites, and also scan all other sites if they were made with WP.
    Also, if you look at most WP sites, they all looks the same, it’s almost easy to see what site was made with it…
    The problem is : almost everybody can easy make sites with WP, and people don’t want to pay more for a website with an Original design, or a hand-coded site.
    People have a WP site, and want to try e-commerce, so what’s more easy then add it to the WP site…
    If you look at the old PrestaShop webshops : many shops are still online with a older version of it, and still have no problems with security issues !
    I’m happy Thirty Bytes is born from PS 1.6 : the scripts have proven to be good since longer times.


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.