Website slow



  • anyone can help me properly … my website is very slow … who can help me please msg or reply me… website is craftshop.site
    my email is mail.craftshop@gmail.com



  • Why dont use the debug function? You can activate it under “performance”



  • Hello @craftshop
    I think you should contact your hosting company if you are on shared servers or go check your WHM (Server Status / Service Status) if you have a dedicated server.
    Your problem might be coming from bots launching a lot of requests on your website (or someone’s else if you are on shared hosting).

    If that’s what you are dealing with, contact your host, and also install this free module from @datakick
    https://store.thirtybees.com/shop-modules/front-office/blackhole-for-bad-bots?search_query=black+hole&results=2

    Otherwise you should indeed activate the debug and see if it could be related to a code modification you might have made.



  • Hey @Gotabor you got me banned from my own website lolol
    Seriously …I installed the module , was very easy and there was no setting up in module only robot.txt
    I dropped the User-agent: * as already had 1 and put the Disallow code directly below # Private pages
    will that be all right there as I have sort of put this off
    sorry am hijacking someone else’s post



  • @craftshop I see that your website is running correctly again. Can you tell us what was the issue ?

    @AndyC glad it could help you too 😉 Little tip, this plugin exists for others CMS like wordpress and is also available as a free script if you need.



  • I have issues with speed too…

    I am using the various caches, loading js at the end and css asynchronously, I set up three cdn to lighten the load (and it has helped somewhat - we have a lot of products and big images), I periodically delete all unused images from the server, clean up the database daily with a script and keep it around 200 MB, using MariaDB, compressed and Barracuda… Yet the page load time is still horrendous (better than it used to be but still). Also anything that requires logging in takes forever. Forever to login, forever to do anything that has to do with the account (when logged in). Not too sure why, nothing really pops up in debug mode.

    The backend overall is fast except when loading images in products - that is dreadfully slow. I run them using imageoptim first but it is still slow.

    I also tried running nginx for static files over Apache using engintron and it worked a bit in the beginning but it does cause issues with some script, getting 504 errors whenever I run search indexing or sitemap for example. I tried various things to extend the timeout but to no avail. These scripts work fine under Apache alone however.



  • Yet the page load time is still horrendous

    If it’s the page in your signature I tried it. Opened Firefox Developer Toolbox -> Network Analysis reads at the bottom right corner after a reload and minutes of waiting:

    0_1541040203871_Bildschirmfoto von 2018-11-01 03-40-03.png

    Compare this to a reasonably equipped page like https://front.thirtybees.com/:

    0_1541040364436_Bildschirmfoto von 2018-11-01 03-45-43.png

    You overcrowded this shop with gimmicks, animation, whatnot to the extent that it loads 20 times as many files and 50 times the download volume. Just keeping the browser window open after these 2 minutes load time causes Firefox to need some 50% CPU load.

    Get rid of all that sh… 🙂



  • For the record, still need some optimizing, but I got the loading speed down to between 2 and 5 seconds from 15 and up. The animations thingies are pretty well optimized. I found the issues was with hooks - lots of modules are set in hooks that I do not use and it seems to be checking every single one of them before uploading any content. By removing the hooks I do not need for some modules, the time to first byte and the loading time increased exponentially! So perhaps it is something worth looking into. Although, a caveat is that you have to make sure you are not removing an essential hook - like I would not touch those in Header and so on, only the display ones (which are probably the ones that are affecting the rendering of the page anyhow).


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.