I have left & right column enabled but they never show up....



  • Strange. I’ve been on this for hours, and searched for hours here. 😞 Sorry, I did try, so I have to ask for help.

    It’s about the left and right columns.

    In my theme, the “edit” theme button is missing. It used to be there. See this:
    www.bryankollar.com/left001.JPG

    Where the horrible circle is, is where it used to say edit. So anyway, when I go into advanced settings, you’ll see I do have left & right enabled
    www.bryankollar.com/left002.JPG

    And finally, I have my item hooked to the left, here:
    www.bryankollar.com/left003.JPG

    So… Why doesn’t anything show?

    Desperate for help. Please. Thanks. I’ll give some a free cookie and coffee for helping lol



  • re #1) missing ‘Theme configurator’ button – this button is available only for theme with name ‘community-theme-default’. It does make sense to display this button for themes that are derived from this theme, though. If you want to show this button for all themes, you can edit file classes/Theme.php and change lines

    if ($themeArr['theme_name'] == 'community-theme-default') {
      $themeArr['tc'] = Module::isEnabled('themeconfigurator');
    }
    

    to simple

    $themeArr['tc'] = Module::isEnabled('themeconfigurator');
    

    Thirtybees should however come up with some better way to associate themes with their respective configuration module(s).

    re #2) turn on your left/right column on individual pages as well, then your content should display on those pages
    0_1540967921255_bbd1cbcc-87f5-4c74-a6a2-22f1d89cc784-image.png



  • Hi, Datakick! OK, I will alter that file so I can get my edit button back. Thanks! But as far as #2 goes, yes, I did forget to mention that I have selected the left and right as indicated above in your snapshot. Any idea why they are still not showing?

    THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU!



  • No one else? 😞 Sigh…



  • I’ve tested it and it works on my 1.0.7 as expected. Verify that you have themeconfigurator module enabled. You can also check that this module is in list of hooks called for left/right columns:

    0_1541082082885_95a971e9-0432-4480-99b4-b42a5f57ba40-image.png



  • @datakick Well, thank you very much. That helped - I’m a lot closer. Your direction led me to seeing the “reset” button. I never remember seeing it before. So - I clicked that. NOW, I can see the left hand side block, BUT it’s only after I view a product or navigate through the website. If I can get the left hand block to show on the main page, I’ll be all good to go. Can you tell me how to do this now that I can see it on the pages within the site (before I couldn’t)

    THANKS



  • Main page is generated by index controller, so just enable left column for it:

    0_1541140017391_67d31033-7eb4-4633-8a4f-321dd6f3e028-image.png



  • AND… That solved it! DataKick, thank you for being the only one to answer. It now works. 🙂 My block is towards the bottom though, so I will search and see how to move it to the top. You’re the best!


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.