Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

simchgab

When installs theme presta 1.7

Recommended Posts

Hi, My question is, when we can install themes for prestashop 1.7, I can see the thirty bees its based in prestashop 1.6. The themes see of 90' haha.

Anyway congratulations for this great great job, and Fu** you prestahop haha. burn it :p

Share this post


Link to post
Share on other sites

We are not planning on supporting prestashop 1.7 themes, we are going to move into a different direction in the future.

Share this post


Link to post
Share on other sites

Sorry jumping in here as it's a burning question I have. Next year I plan on bringing my main site over as well to TB. While I am happy with the default template for my new website do you plan to support other templates . As I would prefer another template for it. My worry with buying a prestshop template is that in the future it stops working with TB and some of them are not cheap
TIA

Share this post


Link to post
Share on other sites

There was an effort to add a compatibility layer for PS 1.7 themes: https://github.com/Traumflug/thirtybees/commits/theme17 It turned out to be a really huge effort, essentially duplicating all the rendering logic. Which means a whole lot of complications and as such, likely a lot of bugs and reduced performance. And unsolved questions, like how to make PS 1.6 modules rendering into PS 1.7 themes. Unless there's a $100,000 Crowdfunding, it's not likely to happen. This effort made barely the front page loading, without modules.

My worry with buying a prestshop template is that in the future it stops working with TB and some of them are not cheap

The whole point of thirty bees' existence is to not break compatibility. We'll always provide backwards compatibility and smooth upgrade paths.

Share this post


Link to post
Share on other sites

@traumflug said in When installs theme presta 1.7:

There was an effort to add a compatibility layer for PS 1.7 themes: https://github.com/Traumflug/thirtybees/commits/theme17 It turned out to be a really huge effort, essentially duplicating all the rendering logic. Which means a whole lot of complications and as such, likely a lot of bugs and reduced performance. And unsolved questions, like how to make PS 1.6 modules rendering into PS 1.7 themes. Unless there’s a $100,000 Crowdfunding, it’s not likely to happen. This effort made barely the front page loading, without modules.

My worry with buying a prestshop template is that in the future it stops working with TB and some of them are not cheap

The whole point of thirty bees’ existence is to not break compatibility. We’ll always provide backwards compatibility and smooth upgrade paths.

ok, in this case, I understand, the objetive is maintain this compatibility whit all modules for prestashop 1.6 always?

More work for have a front very beauty or "fresh" but Is more important the cms work great up vs crash everywhere all the time but having a fresh front, The beauty of front is solved with css :D

applauses for this proyect

Share this post


Link to post
Share on other sites

Then its time to add new crowdfunding for new modern default theme ? we have some thoughts form this discussion https://forum.thirtybees.com/topic/1760/any-plans-for-the-community-theme and other threads

How much crowdfunding do we need to achieve this?

Share this post


Link to post
Share on other sites

@Traumflug tb will not and can not be "always" backward compatible with 1.6. At some point it will have to break. The question is when. 1.1, 1.2, 1.3 ?

For any developer to devote time and man hours to make a 1.6 module or theme work with tb, developers need to have a clear roadmap so they can evaluate if they are going to make money or not.

@Jonny is one of the most popular theme developers and has only one of his themes compatable with tb. Image him (or any other developer) spend time on tb and take time away from the developing things for ps 1.7 where most of their customers are. This is not efficient.

Even spending time and money on the current theme does not make sense if eg in one year we are going to break things.

In order for this to happen IMO we need a clearer roadmap. This is not clear for now. There are to many questions unanswered. Will 1.0.x just stay a less buggy ps version. Will it have new features, when will the team start planning 1.1, what features are planned.

Share this post


Link to post
Share on other sites

My view is that the community theme is decent, at least for folks like me who are happy with a neat design, a slider or two etc. If the theme configurator itself could be enhanced for a few more options for fine grained control on colors and fonts, to me that would cater to most merchants' needs.

 

 

Share this post


Link to post
Share on other sites
4 hours ago, nickon said:
@Traumflug tb will not and can not be "always" backward compatible with 1.6. At some point it will have to break.

The next one spreading fear without any evidence. *sigh*

4 hours ago, nickon said:
> In order for this to happen IMO we need a clearer roadmap.

The roadmap is: "thirty bees will stay compatible with PS 1.6 themes". Not sure what's unclear about this. If you have evidence this doesn't work out, like actual bugs with the newest thirty bees, please report them on Github.

Share this post


Link to post
Share on other sites

@Traumflug You do understand the meaning of the word "always" Yes? Always means that in 10 years (yes tb will exist then :-)) the themes and modules of version 7.0 of will be compatable with ps 16. And no the roadmap does not state this. I remember @lesley also talking about breaking things at some point but I am to busy to look for that post.

I am not spreading fear, I never have. tb should not be afraid anyway if breaking things is smooth and if it is nessesary for the project to move on. But if you can guarantee that it will "always" be compatable with 1.6 well I will take your word for it and we will see who is wrong in the future. Just wanted to state that I feel insulted 😞

Share this post


Link to post
Share on other sites

Insulted from what? From some things maybe breaking somewhere in the future? And thirty bees stating "Ha ha, we fooled you!" ? Come on.

The whole point of thirty bees' existence is keeping compatibility with existing shops. Risking this would be suicide. With this in mind, merchants can trust that thirty bees won't do this.

Actually, current work risks the opposite. Many people consider the project to be not moving, because there are so few new features. This risk is taken to put available resources into making it even more reliable, to make updating ( = bug fixes!) safer, to avoid breaking things. And this emphasis on reliability will be continued, of course. Even when deprecating and removing really old stuff like PHP 5.5 or PS 1.4 support.

Share this post


Link to post
Share on other sites

Insulted that you said I am spreading fear.

So you are still stating that tb will NEVER break compatability with 1.6. OK will be fun to see this in the future

Share this post


Link to post
Share on other sites

@DRMasterChief but he started it (just kidding) 

On a serious note, the main developer should be a bit more carefull when accusing someone of spreading fear. "without any evidence" And since evidence is an issue here are some posts with evidence. Hope this is evedence enough. Damn! I rairly get this upset. Sorry 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...