Product preview leads to wrong url



  • I just installed a ThirtyBees for direct test of the Cloudways / DigitalOcean auto installer.
    In the page “AdminProducts - in list” or “AdminProducts - Edit product” when clicking the “Preview” button the url leads to an Error page.
    Comparing the url of the preview button to the “friendly URL”, I find it to be totally different.
    I already configured the “Preferences / SEO & URL” … I already deleted the .htaccess and continue this way.
    Is it a BUG or something that can be solved with configuration or change to something in the database?

    I hope this question can help others who are going through this problem in the future.
    Hugs!!

    0_1542324345973_error.png



  • Are you using multi-store or anything like that? Or just a regular shop?



  • Hello @lesley !
    I’m using normal store.
    I’ve seen where the error is.
    My SuperUserAdmin is as pt_br and the store was with default language en_us.
    I set the default language to pt_br, the same as my user’s language and returned to normal 😕



  • I have the same problem.



  • Are you using default schema of urls?



  • Hello @30knees !
    Does your store have multi languages?
    If yes:

    • Make sure the default language of your store is the same as the language you use in the BackEnd.
    • If they are different just change the language of the BackEnd in “My preferences” to the same language as the BrontEnd and see if it solved! In my case it solved 😃


  • @datakick It’s the bug that @israelans solved. But yes, I believe it’s the default schema.


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.