Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

haylau

Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability

Recommended Posts

I have been doing a lot of testing and I like the thirty bees environment and systems

I am really keen to keep with the PS 1.6 basis.

So while there a some of our modules giving problems, I was willing to put up with those and change our ways.

BUT - our website needs the Advanced Search 4 module by Presta-Addons. It is not compatable with thirty bees. I have chatted with them, and they are not likely to make it compatable either.

So we are stuck. Our website runs on filtering with ranges and I can find no other way to do this other than the Advanced Search 4 module

I will keep an eye on you all going forward and wish the project every success but i feel at this time i will need to stick with PS 1.6 and all it's shortcomings

Share this post


Link to post
Share on other sites

It's strange that ps16 module won't run on thirtybees. If there's some compatibility issue, it should be fairy easy to iron out, either in tb core or in module itself. I'd be happy to check your module compatibility for you.

On related note - have you tried elasticsearch module? It might be good replacement, and it would speed up your shop as well

Share this post


Link to post
Share on other sites

I haven't looked at elastic search. Does it allow filter searches based on feature ranges?

So for example we have U-bolts and they come in different sizes. We have a feature called "Distance between legs of U-bolt" we need to be able to set that to 0-10, 10-20, 20-30 etc and then the customer can choose a bracket and then move on the the next search criteria

I would be happy for you to investigate and see if you can solve the issue. What details would you need?

Share this post


Link to post
Share on other sites

@haylau I haven't tested ES yet. I supported the Indiegogo project because I also need an advanced search function. I sell boardgames and have set multiple features for 'skills'. One should be able to filter like this: 2-4 players, 10-20 minutes playing time for which you need skill A, D, and F. I was told by the developer that with the ES module it would be possible to do these kinds of filters, so I assume what you want should also be possible.

Share this post


Link to post
Share on other sites

@vincentdenkspel Just had a quick look and it looks more like a much improved search. but we need filtering

You can see what I mean here:

[https://www.u-bolts-r-us.co.uk/125493-u-bolts](link url)

It has to be visual, it has to be multiple choice etc a there are so many combinations available. I don't want to move away from this idea as it has taken years to develop and really helps our customers narrow down to the correct item for their needs

Share this post


Link to post
Share on other sites

@haylau I was specifically told by the developer that very advanced filtering is possible with the module. More info on the module can be found at https://www.indiegogo.com/projects/elasticsearch-module-for-thirty-bees-ecommerce/x/16900365#/ I think this module can do what you are looking for

Share this post


Link to post
Share on other sites

I can see it might allow filters, though without documention and front end examples it is difficult to tell. From the back office of th module I can see i can set filters on the features, but only as checkboxes, not as ranges. if I have checkboxes there could be hundreds.

let me explain it this way, we have 1 u-bolt that hs 11 mm between the legs, another with 12mm, another with 13 mm etc all the way up to over 800 mm between legs. So we have to have ranges, not just tick boxes (actually selectboxe are even better to minimise screen use. Then those u-bolts could be M6 or M8 or M12 or M16, then they could be znc plated or galvanied or stainless steel, then they could have 20 mm inside height or 21 mm inside height all the way up to over 1000 mm inside height. Ranges are the only way.

Share this post


Link to post
Share on other sites

@haylau said in Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability:

I have been doing a lot of testing and I like the thirty bees environment and systems

I am really keen to keep with the PS 1.6 basis.

So while there a some of our modules giving problems, I was willing to put up with those and change our ways.

BUT - our website needs the Advanced Search 4 module by Presta-Addons. It is not compatable with thirty bees. I have chatted with them, and they are not likely to make it compatable either.

So we are stuck. Our website runs on filtering with ranges and I can find no other way to do this other than the Advanced Search 4 module

I will keep an eye on you all going forward and wish the project every success but i feel at this time i will need to stick with PS 1.6 and all it's shortcomings

What is not working? We are using AdvancedSearch Module on our TB shop...

Share this post


Link to post
Share on other sites

@wakabayashi said in Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability:

module

@wakabayashi it is the criteria. Once a criteria is created it cannot be modified. We make a change and click save. The pop up says it is saved, but the changes are not saved at all. I believe it is linked to those criteria with ranges but I have not had time to fully check. Too busy actually selling to spend much time investigating

Share this post


Link to post
Share on other sites

@haylau are you sure this is tb related? I mean it sounds like a bug in the module... And we also had it once, that it said saved and didn't. I complaint at the devs and they gave me a fixed version.

Share this post


Link to post
Share on other sites

Well the module devs basically just says: "I don't care for tb". At least we are using it with tb. If there are not more details, I don't think this problem can be solved...

Share this post


Link to post
Share on other sites

@haylau said in Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability:

@wakabayashi said in Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability:

related

As certain as I can be, yes. We have the exact same module configuration on PS1.6 and it works fine. Tb is practically a clean installation so not really anything else to get in the way. The module devs confirmed and did not offer to help

Did you ask for help? When i have an issue i dont even mention i use tb when its on a tb shop, i just declare the problem and give the credentials to check the problem. I never have had a refusal for my questions. I can imagine the developer can say: ok we will fix it but it will cost you some money.

For what its worth: i also use this module and it works fine on thirtybees(is in dev status) but as i see you also use the features as a filter. Thats what i am not doing at the moment.

Share this post


Link to post
Share on other sites

@baarssen said in Think we will have to leave Thirty Bees - No Avanced Seach 4 compatability:

Did you ask for help

Yes of course

Their reply

"We did not tested, and we do not officialy support thirty bees. The core isn't the same as PrestaShop, and it would be hard to make a lot of conditionals regarding this solution."

features as a filter Yes, it is actually using ranges for filters which I think causes the problem

I will keep looking and trying. But for now we will stick with PS, until I have a little bit more time. I will switch, i am certain, but I need time as too many of our modules are problematic and I just don't currently have time sit and play

Share this post


Link to post
Share on other sites

@haylau Ofcourse is the continue of your webshop the most important. You can also do your migration by the thirtybees team. Costs are very reasonable and it removes your headache :)

Share this post


Link to post
Share on other sites

@haylau

Their reply

“We did not tested, and we do not officialy support thirty bees. [...]

Simply don't mention thirty bees.

[...] The core isn’t the same as PrestaShop, and it would be hard to make a lot of conditionals regarding this solution.”

That's clearly wrong. There are no conditionals needed, because all changes to core are either extensions or backwards compatible.

Share this post


Link to post
Share on other sites

thats already what i thougt because it works flawless on my webshop. I dindt want to say it lou because i am not a developer. At the other hand i have very good experience with this developer(presta module/ business tech) It should be a win win situation if they officially supported thirtybees. Their modules are very good.

Share this post


Link to post
Share on other sites

This is indeed a compatibility problem in thirtybees core. I've filled an issue here: https://github.com/thirtybees/thirtybees/issues/786

Share this post


Link to post
Share on other sites

@datakick Great work. So I can downlod the file from this link and replace the existing one?

https://github.com/thirtybees/thirtybees/commit/882ccef588590cb49dfc664ab0da6481a7a1dc12

Or do I need to wait for an offical update?

Share this post


Link to post
Share on other sites

@haylau sure, you can download and use the new version right now. Or you can wait, as it will be part of the next tb release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×