Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

lesley

Paypal module and Bees Blog updates released

Recommended Posts

I have just pushed live a release for the Paypal module that fixes the "An error occurred" message. 

 

I also released an updated version of the Bees Blog, with several new SEO focused features, bug fixes, and some new hooks for the module. 

 

Both releases should be live in your back offices. 

  • Like 5

Share this post


Link to post
Share on other sites

I updated the blog, but I now can't edit or add any posts or categories because of missing database tables/columns. 
On my staging I did a reinstall/recovery of the blog module and the tables where added. This solves the problem but deletes all the settings, posts and categories.

 

Share this post


Link to post
Share on other sites

The order confirmation page is exactly what I needed!
I hacked something together but it was ugly. Thank you!

Share this post


Link to post
Share on other sites

Hmm there might be a bug in the new blog module, I am going to have to test.

 

@Janvier thank @datakick for that, he added it right before I released the module, to make a good update a great update. 

Share this post


Link to post
Share on other sites
10 minutes ago, lesley said:

Hmm there might be a bug in the new blog module, I am going to have to test.

 

@Janvier thank @datakick for that, he added it right before I released the module, to make a good update a great update. 

First of all thanks for the updates! Forgot to say that!
After I added the columns in the database manually it works. 

Share this post


Link to post
Share on other sites

After upgrade the Paypal I receive this error:

Authentication failed due to invalid authentication credentials or a missing Authorization header.

 

Share this post


Link to post
Share on other sites

Could you try to re-enter or rest your paypal api creds. Nothing in that portion of the module was changed. Are you getting this error on the front or the back? 

Share this post


Link to post
Share on other sites

Can you try to refresh your creds in the module and see if it still happens. 

Share this post


Link to post
Share on other sites

It gives me the same error and still when I try to uninstall or delete I receive a 500 error.... which is strange....

Share this post


Link to post
Share on other sites

The old module or the new module? I suggested to delete the new version through ftp so it does not erase your settings. 

Share this post


Link to post
Share on other sites

The problem happend with the new and the old version. Probably the best is to delete all the settings and begin again configuring PayPal it's possible ?

Share this post


Link to post
Share on other sites

That could be a good option. I would try first with the new module from the feed from scratch. If that does not work, try with the version I linked. 

 

There should not be anything in the new version that causes that error though, that part of the module was untouched. What paypal method are you trying to use? 

Share this post


Link to post
Share on other sites

The problem is that I can't delete completely it gives me Error 500, there is a manual method to delete the module ?  I use live method !!

Share this post


Link to post
Share on other sites

Ftp in and delete the paypal directory in the module folder. 

Share this post


Link to post
Share on other sites

All the versions give me the same error: 

Authentication failed due to invalid authentication credentials or a missing Authorization header.

But also when I try to uninstall totally the paypal module I can't because when I reinstall the module all the previous configuration was saved. On the other hand if I try to uninstall or delete the module completely from the back office it gives me the error 500.

 

Share this post


Link to post
Share on other sites

I guess first I am trying to fix the payment issue, the uninstall issue is less important currently. 

 

Did you site use this module before and take payments? 

Share this post


Link to post
Share on other sites

Have you generated new paypal api keys? The error you are getting is a key error. If it worked fine before, rolling back the module should fix the module. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×