Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

cprats

[SOLVED] Can't create customer account after uploading the community theme

Recommended Posts

Hello, I'm in a big trouble. I use TB1.0.8, imported from PS. I kept the default theme of Prestashop until a few days ago, that I decided to upload TB's community theme. Since then, I can't sign up for an account on my site (but I can log in with previously created accounts).

Any suggestions?

Edited by cprats
Solved

Share this post


Link to post
Share on other sites

WHat sort of error messages do you get.

Try disabling all add ons and try. Double check address settings

Share this post


Link to post
Share on other sites

There are no error messages. I've noticed that you can only sign up if you set Canada as your country. This may be just a configuration issue I am not able to see.

Geolocation is set to NO and all countries are enabled under Localization / Countries.

Share this post


Link to post
Share on other sites

I had a similar issue when I first set up ( couldn't sign up)  .. I started from scratched and did 1 country at a time ...also try leave the postcode blank that gave me a hard time too

 

Share this post


Link to post
Share on other sites

Update: this problem only happens with Firefox and with TB community theme. When I try to sign up, the register screen sets Canada as default country. If I change the country, when I click the register button no actions are done neither error messages appear, but the result is nothing.

If I try with Chrome, nothing of this happens. Spain appears as default country when signing up (I guess because it detects the country where I am through IP) and I can sign up with no problems.

To avoid this issue I must change to prestashop's default-bootstrap theme, which is the one I imported when I migrated the sop to TB.

Share this post


Link to post
Share on other sites

SOLVED:

Under Localization - Configuration, I've set up "Set default country from browser language" to NO and it worked.

Edited by cprats
typo
  • Like 1

Share this post


Link to post
Share on other sites

I'm having this same issue as from community theme I can register only from USA country.

And it's not alowing any other country, as register button does not respond, no matter what I set in BO configurations, all cache cleared and everything.

This is happening on totaly default TB instalation freshly installed through Softaculous and all countries enabled.

 

But it works if I replace complete #account-creation-form in authentication-create.tpl with the one from prestashop.

 

<form action="{$link->getPageLink('authentication', true)|escape:'html':'UTF-8'}" method="post" id="account-creation_form" class="std box">

  with everything included between first and last line
  
  
</form>

 

Edited by toplakd

Share this post


Link to post
Share on other sites

Currently narrowed my issue down to following div: <div class="account_creation">

 

Edited by toplakd

Share this post


Link to post
Share on other sites

If the Default country in shop is set to one that contains states, than one from county without states can not register as state required is automaticly applied once opening registration form.

But if Default Country has no states, than it works as it was intended in the template as required is only set once country with state is chosen.

So could this be called a bug as the state required tag is not changing properly once country is selected ?

 

Prestashop Themes do not have required tag on <select name="id_state" ....  >

And address.tpl also does not have required on the select state.

 

{elseif $field_name eq "State:name" || $field_name eq 'state'}
{assign var='stateExist' value=true}
<div class="required id_state select form-group">
<label for="id_state">{l s='State'} <sup>*</sup></label>
<select name="id_state" id="id_state" class="form-control" required>
<option value="">-</option>
</select>
</div>
{/if}

 

Edited by toplakd

Share this post


Link to post
Share on other sites

I wish we could completely do away with State dropdown list ... More and more websites I visit now have a normal fill in box and is much better as nothing worse than the website not having your State

Share this post


Link to post
Share on other sites

Required should be removed from that <select state, as not all countries have states and this makes confusions.

This is something i found only on community theme and this brings out issues when shop default country uses states.

So therefore it should be removed so theme can be operational no mater of default country.

 

I know required was put there with good intentions, but no one has tested how  it functions if default shop country has states, but customer comes from country without states.

In my opinion one should first choose the country and than the fields for postcode and state will show up if they are needed.

 

1.Country:

2.Address 1

3.Address 2

4.City

5.State

6.Post

 

That layout would solve the issues where customer does not have states, and country selection is below post code field and state field.

I realized this as my shop has USA as default county, as more than 50% customers are from there.

But i was testing my tabbed login and could not register from my country.

So installed clean fresh TB on another instance to see if this was my fault.

Then i realized it's not my fault, as it has something to do with the Community-theme by default.

So after comparing PS themes to TB I saw TB is using required on most of <select options, and removing the require on state solved this.

Edited by toplakd

Share this post


Link to post
Share on other sites

What is mentioned above should realy be changed in the upcoming version.

As many shop owners don't even realize that If shop default country contains states, and they have account creation with address,

than customer (which comes from country that does not have states) can not register in their shop.

This can be very easily verified. Fresh TB has default country USA, then enable one or more countries that does not have states.

Than try to register new account with that country. No-go 🙂

 

Share this post


Link to post
Share on other sites
16 hours ago, toplakd said:

What is mentioned above should realy be changed in the upcoming version.

Fixed in community theme. Unfortunately this will not fix any theme based on community theme, ie. niara.

  • Thanks 1

Share this post


Link to post
Share on other sites

Tommat has fixed this in Niara yesterday, just didnt have time to upload the recent version.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×