Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Binder

Csv import gives “Errors occurred:  error” when trying to upload using ID, Stock QTY and Price.

Recommended Posts

Good day all

Please advise on how to trace what is causing the below error on my site when uploading csv?

Csv import gives “Errors occurred:  error” when trying to upload using ID, Stock QTY and Price.

Sometimes I will receive the error at 3% uploaded then when I try again with the same csv I will get the error at 15% or 85%. The csv uploads correctly on my other site so there is nothing wrong with the file. I’m using the below PHP settings and also tried higher settings.

  • max_execution_time=6000
  • max_file_uploads=50
  • max_input_time=10000
  • max_input_vars =10000
  • memory_limit=1G
  • output_buffering=4096
  • post_max_size=256M
  • session.gc_maxlifetime=1440
  • upload_max_filesize=128M

I'm using thirtybees 1.0.8

I have also tried importing with below changes.

Template compilation set to: Never recompile template files

Disabled all non thirtybees modules and overrides

Set all of the below settings to NO

  • Smart cache for CSS
  • Smart cache for JavaScript
  • Compress inline JavaScript in HTML
  • Move JavaScript to the end
  • Apache optimization
  • Keep JS and CSS files

Share this post


Link to post
Share on other sites

@Binder are there any error messages listed in /logs directory (located in thirtybees root) ?

Share this post


Link to post
Share on other sites
On 4/6/2019 at 1:44 PM, datakick said:

@Binder are there any error messages listed in /logs directory (located in thirtybees root) ?

I did activate debug mode but there are no log files available under the logs directory.

Share this post


Link to post
Share on other sites

I guess that's a time-out error

1. Enable the "Skip thumbnails regeneration" option, because generating thumbnails would cost a lot of time, you can generate thumbnails later. 

2. Split your csv files to small ones, like 10 products per file.

Share this post


Link to post
Share on other sites
1 hour ago, Jonny said:

I guess that's a time-out error

1. Enable the "Skip thumbnails regeneration" option, because generating thumbnails would cost a lot of time, you can generate thumbnails later. 

2. Split your csv files to small ones, like 10 products per file.

I'm only importing ID, Stock QTY and Price with "Skip thumbnails regeneration" Enabled. I'm not uploading new product, just updating prices and stock.

Updating 10+ products is not an option as I need to update 25000 products daily.

The csv file i'm using uploaded without any errors on my other website so this must be a server or website problem. I have also tried different hosting and PHP settings as per above post.

Share this post


Link to post
Share on other sites

I struggled to upload csv files and found this in the forum

@hedgehog that's definitely enough memory. So the culprit must be somewhere else. Could you please try to modify this line in classes/Tools.php and change it to look like this:

'verify' => _PS_TOOL_DIR_.'cacert.pem',https://forum.thirtybees.com/topic/2380-2380/csv-product-import-error-copying-image/?page=0#comment-23653

after changing it i could upload csv file .you might have to regenerate images .

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/9/2019 at 6:04 PM, M5150 said:

I struggled to upload csv files and found this in the forum

@hedgehog that's definitely enough memory. So the culprit must be somewhere else. Could you please try to modify this line in classes/Tools.php and change it to look like this:

'verify' => _PS_TOOL_DIR_.'cacert.pem',https://forum.thirtybees.com/topic/2380-2380/csv-product-import-error-copying-image/?page=0#comment-23653

after changing it i could upload csv file .you might have to regenerate images .

 

Just checked, I see I have already tried that:(

 

Edited by Binder

Share this post


Link to post
Share on other sites

Try this  i had a problem with uploading csv files .When uploading look at you're csv file that there are no incomplete data left behind ,delete them .

should upload .use open office .convert to ods. format.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...