Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

LauraJ

Converted from HTML store to thirty bees

Recommended Posts

Recently converted my store from a long-standing strictly HTML store with Mals-ecommerce shopping "cart"

SALES HAVE PLUMMETED.  a small fraction of what they were.

Can you help a girl out and visit the store.  See if it's working right?  See if it's aesthetically pleasing...

HELP 

 

https://naildots.com

 

THANKS IN ADVANCE

Share this post


Link to post
Share on other sites
Posted (edited)

I did not tests on technical things  (if checkout works....), shop seems to be fast,  but maybe you can find an other (nicer) Theme, this is not very attractive to me  (a male  :) )   Do you use the Niara theme?  Then the nice and clean look is lost, sorry to say this.

Also the black line around each pic, why is this?  Maybe you should reduce this to a small line, not that bold, and without your URL,  so it would be more professional. 

There is the same description on each item,  a super no-go for google....   and it is not very meaningful. 

Also text like  ....What Others Love Most....

this does not appeal the customer,  you are talking about 'others'  and not THE customer.  Think about it and maybe check some bigger shops with e.g. fashion,  i think you can get a lot of ideas from there also for your business.

Edited by DRMasterChief
  • Like 1

Share this post


Link to post
Share on other sites

This is one very important cause. Like Lesley said you did not redirect your urls. Google has to index your site again and it takes minimum several months to reach the same results.

So I will advise you to redirect all you old urls to the new ones asap.

 

image.thumb.png.4091c945d1d79a11f05647d75f351387.png

 

  • Like 1

Share this post


Link to post
Share on other sites

I think the main problem is the menu. Everything is under "Nail Decals". But you only discover that when you move your mouse over the word. You should find a way so that it becomes clearer on the home page what kinds of things you sell. Maybe a menu at the side or one image for each category.

"Custom Decals" is an empty category. And "Details" is rather empty word. I would guess that most people would search the info in the footer. 

  • Like 1

Share this post


Link to post
Share on other sites

Thank you - I will work on the redirects.

I'm having trouble finding themes for thirtybees can someone help me find other ones?

Share this post


Link to post
Share on other sites

I'm getting errors on my own site (after no sales for 10 days..... I finally checked) 

Too many redirects

This page isn’t working

naildots.com redirected you too many times.

ERR_TOO_MANY_REDIRECTS
 
I've cleared my cookies (PC) ... still won't load.  Site works on my phone though.  Any ideas from my tech savy friends?

Share this post


Link to post
Share on other sites

it works from my phone too.  Just not on the computer.  Chrome.

I had set all my redirects within the htaccess page for all pages of the website.  It seemed to work fine.

Now I'm getting errors as are others apparently.  

Share this post


Link to post
Share on other sites

I'm getting redirects as well:

1496190467_Bildschirmfotovom2019-05-1619-22-09-or8.png.8c16d88f262c56ad53f226d099356f71.png

At back office -> Preferences -> General, did you turn on Enable SSL as well as Enable SSL on all pages ? IIRC this is the secret.

The latter switch is on the list of getting removed, having sites with mixed security made sense 10 years back for performance reasons, but these days are gone.

Share this post


Link to post
Share on other sites

Why is the main URL redirecting me to https://naildots.com/items/ 

maybe you did something wrong with the redirects?

Could you post one example redirect link. Old and the redirected url, so someone could help you?

Share this post


Link to post
Share on other sites

Yeah the main url is redirecting to /items/. But for me (Chrome) this just works.

Sometimes things are strange :classic_blink:

nail-dots.JPG

Share this post


Link to post
Share on other sites
Posted (edited)

Not working for me. (both chrome & firefox)
Says it's not redirecting properly.

Homepage trying to redirect to https://naildots.com/items/  as mentioned above and fails.

Edited by Purity

Share this post


Link to post
Share on other sites

my original site was all html coded, no store front / cart. original site was http://www.naildots.com 

I recently transferred to thirty bees.

the new site is https://naildots.com/items

 

another sample would be 

http://naildots.com/4th-july-nail-decals.html

to http://naildots.com/items/fourth-of-july-nail-decals

 

this one has a new meta tag - <meta http-equiv="refresh" content="0; URL='http://naildots.com/items/fourth-of-july-nail-decals'" />

I was using the htaccess page with all of the pages listed

ie

 

Redirect 301 /halloween-nail-decals.html https://naildots.com/items/Halloween-Nail-Decals
Redirect 301 /4th-july-nail-decals.html http://naildots.com/items/fourth-of-july-nail-decals
Redirect 301 /about-nail-dots.html http://naildots.com/items/info/details/about-us
Redirect 301 /animal-nail-decals.html http://naildots.com/items/animals
Redirect 301 /april-holiday-nail-decals.html http://naildots.com/items/seasonal

Share this post


Link to post
Share on other sites
3 minutes ago, LauraJ said:

this one has a new meta tag - <meta http-equiv="refresh" content="0; URL='http://naildots.com/items/fourth-of-july-nail-decals'" />

This is the problem. Such a redirect shouldn't be there.

And all HTTPS, please 🙂

Share this post


Link to post
Share on other sites

I've moved everything back to the htaccess page 

I've changed to https

 

fourth of july has 2 pages within thirty bees, the one I gave is correct --- the one you listed is empty...  

Share this post


Link to post
Share on other sites
Posted (edited)

You should try traumflug’s advice, I don’t know what he exactly means, but for me whatever link i try to follow on your site it redirects me to same page ... and it only works with _ not with -

Check the previous setting he mentioned with the ssl setting. You should try to regenerate your htaccess file and just add the redirects in the new generated file.

I just get it, the page I open is obviously your 404 page ... So definitely don’t follow anything I say, just traumflug’s advice 😉

Edited by MockoB

Share this post


Link to post
Share on other sites

I contacted my hosting support - theyve disabled the htaccess 

Now nothing in my thirty bees installation is working at all.  I can't even get to traumflug's area to make the change.

 

Why can't life be simple?

Share this post


Link to post
Share on other sites

"At this time, we have disabled the htaccess in the public_html and the main page of the site is loading. However, the /items page appears to still be redirecting.
We strongly suggest that customers consult with a professional development service to better serve their needs. 
If you or your developer or consultant identifies changes needing to be made to the server to accommodate your needs, please let us know and we will be happy to address those needs.
If this issue persists, or if you have any further questions regarding this issue, please feel free to reply to this ticket."

Share this post


Link to post
Share on other sites
Posted (edited)

"Unfortunately, this configuration is outside the scope of support we can offer. We recommend that you consult with a web developer who is familiar with the scripts you are running and work with them to program the .htaccess file to accomplish your goals. Currently all standardized .htaccess commends used to redirect the domain to a sub folder are generating too many redirects. This issue actually lies in the .htaccess file located in the /items folder and potentially the script that is being run within."
 

Edited by LauraJ

Share this post


Link to post
Share on other sites

I was just going to tell you how to regenerate your htaccesss file, but it looks your site is working fine now. I’m happy you solved it. Could you please tell us what the issue was?

Share this post


Link to post
Share on other sites

I removed all of the redirects in the htaccess except for the main page. 

I also checked the items in Traumflog's advice At back office -> Preferences -> General, did you turn on Enable SSL as well as Enable SSL on all pages ? IIRC this is the secret.

 

However, I'm still faced with the issue that the OLD site has 50 product pages where all I can do is request that people click a link.  I can't do a redirect in the main htaccess page for all of these pages

can i redirect on each page?  Traumflog's advice above said that's not a good idea....

Share this post


Link to post
Share on other sites
Posted (edited)

The way I’m redirecting in the htaccess file is: 

redirectMatch 301 ^/oldcategory/oldproduct$ /newcategory/newproduct/

The redirect is placed at the beginning of the htaccess file. It is working fine for me. Nothing additional, just the redirects.

Edited by MockoB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×