Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Smile

Users see other users names in user block

Recommended Posts

We have some issue with caching or cookies.... We expect at least that is is cookie or cache based. I am not sure where to look and don't get it fixed. 

What happens?

Users do see names from other users. We got this report from multiple different users. But I can not replicate it here.... I have attached the pictures of current settings.

 

We use the login module User block info mod from the panda theme. We use this modele as it is a bit more flexible for locations. 

 

Can someone point me to the direction we could investigate?

cach-user6.JPG

cach-user5.JPG

cach-user4.JPG

cach-user3.JPG

cach-user2.JPG

cach-user1.JPG

Share this post


Link to post
Share on other sites

It looks like full page cache is disabled (unless you use multistore, and the settings for other store is different). That would suggest that the issue is not in thirtybees core, but in the module's caching, if it use any.

Share this post


Link to post
Share on other sites

Hi,

I guess the issue was due to the "Redis" cache. if you are using the native "user info block" module, the issue still persists. so please disable the "Use cache" option and clear the Smarty cache to check whether it works fine or not.

Best regards.

Share this post


Link to post
Share on other sites

Is there any way to test this as customers often have the issue and I myself not.... 

In the other hand we need a form of cache....? What would be the way to go after disabling the cache?

Share this post


Link to post
Share on other sites

Hi,

After you disable the cache, you can contact the customers who experienced the issues to check whether it was resolved or not.

Best regards.

Share this post


Link to post
Share on other sites

@Jonny I'm sorry, but I don't think this is the right answer. If the module is using system cache in a wrong way, then the solution should be to fix the module, not to disable system cache. 

In other words -- if cached content contains customer personal information, then cache key must be based on customer id. If this would result in too many entries in cache, then the module might decide to not use cache for logged-in customers.

But disabling cache at system level is not a solution.

Share this post


Link to post
Share on other sites

Hi,

Sorry, maybe I didn't explain clearly. as I also can't reproduce the issue, so I need to exclude some factors, such as system cache. if you switch to the default "User info block" module, does the issue still persist? if the same issue occurred on the native module, that wasn't due to my "User infor block mod". my module doesn't save any user cache message, it uses the native system cache.

Best regards.

Share this post


Link to post
Share on other sites
51 minutes ago, Smile said:

In the other hand we need a form of cache....?

Not really. thirty bees works entirely fine without any caching. Caching shouldn't change shop behavior other than making it faster.

Also, some caching methods have benefits on one system, but not on another. When enabling caches one should always test whether there's actually a performance benefit. If there is no such benefit, I'd keep it off. Adding complexity without a gain is rarely a good idea.

Share this post


Link to post
Share on other sites

Not sure what is happening, its too complicated for me to solve.... Today one customer managed to order on someone else name (is was logged in under that name) place an order but with its own address.... Ik keep you updated..

Share this post


Link to post
Share on other sites
13 hours ago, Smile said:

Today one customer managed to order on someone else name (is was logged in under that name) place an order but with its own address....

If a customer can log in as another customer s/he can order as that other customer, of course. Adding and address is possible, of course, customers can have many addresses.

Share this post


Link to post
Share on other sites

Seeing another customer name is something else than being logged in.... But it appears both apparently 😮

Share this post


Link to post
Share on other sites

Disable Opcache on the server and test, I have seen that cause issues sometimes. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×