Newly installed thirtybees site won't load - ERR_TOO_MANY_REDIRECTS



  • @mdekker @Global-Moderators

    Admin loads fine. The actual site won’t load in Chrome, FireFox or safari. I’ve deleted all cookies, cleared all cache, deleted history, etc for all of them and closed each browser and restarted each browser. Tried this 3X each for each browser.

    Results from each browser:

    Chrome:
    This page isn’t working
    newshop.alwayspaws.com redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    I used the developers tools and got this:

    GET http://newshop.alwayspaws.com/ net::ERR_TOO_MANY_REDIRECTS data:text/html,chromewebdata:4176

    FireFox:
    The page isn’t redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    This problem can sometimes be caused by disabling or refusing to accept cookies.

    Safari - I couldn’t copy the text it showed but it said the same thing.

    How do I fix this, please?



  • try to regenerate the .htaccess and see if you get any luck.



  • How?



  • Preference -> Seo & URL -> turn on or off friendly urls and save.



  • That did not work. Thank you.



  • Can you turn debug on?



  • And disable friendly url.
    also can you paste the content of your .htaccess file



  • Disabled friendly urls and turned on debug mode.

    Here is the .htaccess contents:

    RewriteEngine on

    RewriteRule .*.(jpg|jpeg|gif|png|bmp|png)$ - [F,NC]

    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://newdev.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^http://newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.thirtybees.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://newdev.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^https://newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.thirtybees.alwayspaws.com/.
    $ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.thirtybees.alwayspaws.com$ [NC]
    RewriteRule .*.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

    start Do not remove this comment, thirty bees will keep automatically the code outside this comment when .htaccess will be generated again

    .htaccess automatically generated by thirty bees e-commerce open-source solution

    http://www.thirtybees.com - http://www.thirtybees.com/forums

    <IfModule mod_rewrite.c>
    <IfModule mod_env.c>
    SetEnv HTTP_MOD_REWRITE On
    </IfModule>

    RewriteEngine on

    #Domain: newshop.alwayspaws.com
    RewriteRule . - [E=REWRITEBASE:/]
    RewriteRule ^api$ api/ [L]

    RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

    AlphaImageLoader for IE and fancybox

    RewriteRule ^images_ie/?([^/]+).(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]
    </IfModule>

    AddType application/vnd.ms-fontobject .eot
    AddType font/ttf .ttf
    AddType font/otf .otf
    AddType application/x-font-woff .woff
    <IfModule mod_headers.c>
    <FilesMatch “.(ttf|ttc|otf|eot|woff|svg)$”>
    Header add Access-Control-Allow-Origin “*”
    </FilesMatch>
    </IfModule>

    #If rewrite mod isn’t enabled
    ErrorDocument 404 /index.php?controller=404

    end Do not remove this comment, thirty bees will keep automatically the code outside this comment when .htaccess will be generated again



  • can you remove all these lines:
    RewriteRule .*.(jpg|jpeg|gif|png|bmp|png)$ - [F,NC]

    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://thirtybees.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.newdev.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.newdev.alwayspaws.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.thirtybees.alwayspaws.com/.$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.thirtybees.alwayspaws.com$ [NC]
    RewriteRule .*.(jpg|jpeg|gif|png|bmp)$ - [F,NC]



  • I removed them and saved, but I did it right from within Admin. Is this correct? Or do I edit .htaccess and upload it via FZ?



  • I posted this part elsewhere but do I need these cookies?
    0_1495431969196_allow these cookies for thirty bees?.jpg



  • it should be fine within admin.
    are you using any caching or module for cache or anything?



  • No, this is a brand new install and I have done nothing except update the modules. It still won’t load.



  • try to rename .htaccess file to .htaccess.old and regenerate again from back office.
    and paste the new content again.



  • Done. Here is the new .htaccess file contents

    start Do not remove this comment, thirty bees will keep automatically the code outside this comment when .htaccess will be generated again

    .htaccess automatically generated by thirty bees e-commerce open-source solution

    http://www.thirtybees.com - http://www.thirtybees.com/forums

    <IfModule mod_rewrite.c>
    <IfModule mod_env.c>
    SetEnv HTTP_MOD_REWRITE On
    </IfModule>

    RewriteEngine on

    #Domain: newshop.alwayspaws.com
    RewriteRule . - [E=REWRITEBASE:/]
    RewriteRule ^api$ api/ [L]

    RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

    AlphaImageLoader for IE and fancybox

    RewriteRule ^images_ie/?([^/]+).(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]
    </IfModule>

    AddType application/vnd.ms-fontobject .eot
    AddType font/ttf .ttf
    AddType font/otf .otf
    AddType application/x-font-woff .woff
    <IfModule mod_headers.c>
    <FilesMatch “.(ttf|ttc|otf|eot|woff|svg)$”>
    Header add Access-Control-Allow-Origin “*”
    </FilesMatch>
    </IfModule>

    #If rewrite mod isn’t enabled
    ErrorDocument 404 /index.php?controller=404

    end Do not remove this comment, thirty bees will keep automatically the code outside this comment when .htaccess will be generated again



  • Can you turn off https from back office



  • You mean turn off SSL?



  • yes



  • Turned it off from admin - general



  • it looks like you have bad redirect from http to https.
    you need to make sure you remove https (just for now), also in seo & url remove the ssl part.
    https://newshop.alwayspaws.com/contact-us - this one loads.
    and it still redirect to https.
    so maybe you have redirect from you dns settings.


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.