Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Traumflug

thirty bees 1.1.0 is released!

Recommended Posts

Posted (edited)

Good news regarding 1.1.0. I am very happy being part of TB community.  

Is it just mine or not, but if try to edit a product, the buttons "save and stay", "save" they keep rolling and cannot save the modifications.

Please reply, ty.

Solved, got issue with browser.

Edited by Jon88

Share this post


Link to post
Share on other sites
2 hours ago, Jon88 said:

Good news regarding 1.1.0. I am very happy being part of TB community.  

Is it just mine or not, but if try to edit a product, the buttons "save and stay", "save" they keep rolling and cannot save the modifications.

Please reply, ty.

Solved, got issue with browser.

lol I had this as well, but yes browser or in my case cloudflare also causes this.Happened after upgrading to 1.1.0

 

Share this post


Link to post
Share on other sites
On 7/26/2019 at 9:44 AM, Jonny said:

@vzex I will talk a look tomorrow, if there are any compatibility issues, then I will fix them and release a minor update. 

We have plans to do a relatively major update for Panda theme v1 to add some features like "Ability to use different image types for different blocks", "Keep images be at their original sizes", "Lazyloading off screen images", "Lazy loading banner images", etc, if they can be added. I think the relatively major update will be released about half months later.

Hi @Jonny received email today for Panda theme v1.5.0 for thirtybees release but back office shows me up to date. Will it be pushed to back office? Thanks!

151772450_ScreenShot2019-08-08at10_00_06AM.png.2d505335d9959e7327705fe7426c011e.png

Share this post


Link to post
Share on other sites

That's weird ...Why am I up to date but lower than you are at 1.1.5

Capture.JPG

Share this post


Link to post
Share on other sites

@andyc the last time I updated Panda last year some time I did it manually since back office update for panda wasn't an option.

Hope this gets updated since I'd rather not hunt for the download then manually update.

Here is the email link I received this morning:

Panda theme v1.5.0 for thirtybees is released, check changelog on this page https://www.sunnytoo.com/product/panda-creative-responsive-prestashop-theme

Had to log in with envato first then under "my account" is the link for downloads from sunnytoo.

I've not updated yet, waiting for the back office update link to work

 

Share this post


Link to post
Share on other sites

Oh OK ... I'll wait for the official update as well as Have some backing up to do first as I have a couple of files that have been changed so they will get overridden

Share this post


Link to post
Share on other sites

@AndyC @vzex I released panda theme v1.5.0 for Thirtybees 1.1.0 yesterday, added new features as I said before, those features would short page loading time a lot, I also added a way to show filters on the center column as drop down lists.

I am going to check why the upgrade button in the theme editor module does't work. Another way is to upgrade your theme manually, take these steps:

1 .Upload the update1.5.0.zip to the root folder of your site.
2. Unzip it.
3. Go to the BO>Modules page, modules will be upgraded automatically.
4. Clear the Smarty cache.

That's all. 

  • Like 3

Share this post


Link to post
Share on other sites

Thanks.... I'll try and upgrade this weekend... I've a few mods to sort out as well first on the Product.tpl as I can assume those will be overridden

Share this post


Link to post
Share on other sites

I want to mention that I shamefully forgot to say thank you! Thank you to everyone who commited her/himself so much to get Thirtybees so far. I am really happy to have come to known of it and to use it. It is a great project!

  • Like 2

Share this post


Link to post
Share on other sites
8 hours ago, Jonny said:

@AndyC @vzex I released panda theme v1.5.0 for Thirtybees 1.1.0 yesterday, added new features as I said before, those features would short page loading time a lot, I also added a way to show filters on the center column as drop down lists.

I am going to check why the upgrade button in the theme editor module does't work. Another way is to upgrade your theme manually, take these steps:

1 .Upload the update1.5.0.zip to the root folder of your site.
2. Unzip it.
3. Go to the BO>Modules page, modules will be upgraded automatically.
4. Clear the Smarty cache.

That's all. 

That's how I upgraded last time, I'll wait until the back office update works since I prefer everything in my dashboard.

Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

@vzex We will soon make the back office upgrade feature work. Currently you can manually upgrade your theme. Do remember to fully backup your site files and database before updating.

Edited by Jonny

Share this post


Link to post
Share on other sites

Yeah I did try that first.

Is Panda update showing up for anyone else?

Share this post


Link to post
Share on other sites

Updated to 1.1 thinking it might show the Panda update but unfortunately I get a 500 page for checking out.

Had to roll back to 1.0.8

 

Share this post


Link to post
Share on other sites

1st update attempt failed .. Featured products and panda blog ended up a single line down the middle of the page rather than as a slider

Share this post


Link to post
Share on other sites

I have now tested tb 1.1.0 with the new template niara.
I have problems with all the checkboxes for the modules AEUC (by TB) and GDPR (by Arte e Informatica).
for GDPR, the checkboxes are not displayed and in the AEUC module also not, such. for the terms and conditions.

Maybe someone has an idea what this may be or a helpful tip?

Thank you very much

Share this post


Link to post
Share on other sites
21 hours ago, Jonny said:

@AndyC @vzex I released panda theme v1.5.0 for Thirtybees 1.1.0 yesterday, added new features as I said before, those features would short page loading time a lot, I also added a way to show filters on the center column as drop down lists.

I am going to check why the upgrade button in the theme editor module does't work. Another way is to upgrade your theme manually, take these steps:

1 .Upload the update1.5.0.zip to the root folder of your site.
2. Unzip it.
3. Go to the BO>Modules page, modules will be upgraded automatically.
4. Clear the Smarty cache.

That's all. 

I did this and it worked just fine.

Share this post


Link to post
Share on other sites
Posted (edited)

The only issue i have is with geolocation turned on the site goes 500.  if i turn off geolocation it works

I have the geo data file installed 

Adding this here as well.

I wasn't sure which issue you want this in I added it to 927. After upgrading to 1.1.0 GeoLocation is broken again.

/** 1903: * Geolocation management. 1904: * 1905: * @param Country $defaultCountry 1906: * 1907: * @return Country|false 1908: * 1909: * @since 1.0.0 1910: * 1911: * @version 1.0.0 Initial version 1912: */ 1913: protected function geolocationManagement($defaultCountry) 1914: { 1915: if (!in_array($_SERVER['SERVER_NAME'], ['localhost', '127.0.0.1'])) { 1916: /* Check if Maxmind Database exists */ 1917: if (@filemtime(_PS_GEOIP_DIR_._PS_GEOIP_CITY_FILE_)) { 1918: if (!isset($this->context->cookie->iso_code_country) || (isset($this->context->cookie->iso_code_country) && !in_array(strtoupper($this->context->cookie->iso_code_country), explode(';', Configuration::get('PS_ALLOWED_COUNTRIES'))))) { 1919: $gi = geoip_open(realpath(_PS_GEOIP_DIR_._PS_GEOIP_CITY_FILE_), GEOIP_STANDARD); 1920: $record = geoip_record_by_addr($gi, Tools::getRemoteAddr()); 1921: 1922: if (is_object($record)) { 1923: if (!in_array(strtoupper($record->country_code), explode(';', Configuration::get('PS_ALLOWED_COUNTRIES'))) && !FrontController::isInWhitelistForGeolocation()) { 1924: if (Configuration::get('PS_GEOLOCATION_BEHAVIOR') == _PS_GEOLOCATION_NO_CATALOG

This is the debug file from the red highlighted line is 1919. I double check with both a converted DB and an Old one. the system shows 500 error either way with this debug. I have to turn off GeoLocation to have the system function.

Edited by Factor

Share this post


Link to post
Share on other sites

@AndyC Sounds like a cache related issue, try clearing the smarty cache and your browser cache.

@vzex The problem you have with TB 1.1 is kinda like a compatibility with one of your payment modules or carrier modules. Do what @Factor did to enable debug mode to see error messages.

@Factor The information you gave out is not enough for me to tell what's wrong.


If you all need more help, then send me your FTP and back office details via our support forums or via private message here.

Share this post


Link to post
Share on other sites
1 hour ago, Jonny said:

@AndyC Sounds like a cache related issue, try clearing the smarty cache and your browser cache.

It was only a trial run with my product.. I have had tabs added to my site and will take a bit more work. I have a  engraving section that unfortunately takes a lot of space , so have to do some file merging 

Share this post


Link to post
Share on other sites
6 hours ago, Jonny said:

@Factor The information you gave out is not enough for me to tell what's wrong.


If you all need more help, then send me your FTP and back office details via our support forums or via private message here.

Jonny. I figured the geolocation is not yours sorry if posting it confused anyone. 

Share this post


Link to post
Share on other sites

Looks awesome.
Has anybody upgraded on warehouse theme?
I am wondering about compatibility.

Share this post


Link to post
Share on other sites

I've upgraded my Panda ...But can I ask have there been any changes to the product.tpl... Every time I mess with it it goes back to the default layout and my tabs are missing

thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×