Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Bill Dalton

Upgraded PS 1.6 to TB 1.0.8 to TB 1.1.0

Recommended Posts

the clean install does have a table not present in the upgraded DB, the table is called tb_themeconfigurator but it only contains info about the TB logo image.

Share this post


Link to post
Share on other sites

The end of the story is the themes work fine. It must have been some legacy piece of code in the override folder. I completely replaced that with a fresh copy from a fresh install and cleared cache. So, very much liking this and look forward to moving it to a new domain and trying it out with PHP 7x - currently running PHP 5.6

Share this post


Link to post
Share on other sites
6 hours ago, Bill Dalton said:

It must have been some legacy piece of code in the override folder. I completely replaced that with a fresh copy from a fresh install and cleared cache.

You should probably delete these overrides completely, if you don't use them anymore.

Share this post


Link to post
Share on other sites

Yeah, I replaced both the override and modules folders with "virgin" copy's from the TB 1.1.0 full download install copy. Now I need to do some testing with a new PHP 7 version and start adding back some updated third party modules and hopefully they will be PHP 7 compatible. I'll try them under PHP 5.6 first.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/17/2019 at 6:46 AM, Bill Dalton said:

The end of the story is the themes work fine. It must have been some legacy piece of code in the override folder. I completely replaced that with a fresh copy from a fresh install and cleared cache. So, very much liking this and look forward to moving it to a new domain and trying it out with PHP 7x - currently running PHP 5.6

We were running same update from ps1.5 to 1.6  to latest tb version but have not encountered any problem.. our server is running on PHP7x .. maybe the php 5x is the issue with your updater..

  • Like 1

Share this post


Link to post
Share on other sites

I'm very surprised to hear you are running PHP 7 with PS 1.5 - I sure could get mine to run with PHP 7 - but that wasn't it, if you read all this thread there is a code change that is needed for a windows install.

Share this post


Link to post
Share on other sites
18 minutes ago, Bill Dalton said:

I'm very surprised to hear you are running PHP 7 with PS 1.5 - I sure could get mine to run with PHP 7 - but that wasn't it, if you read all this thread there is a code change that is needed for a windows install.

Oh, sorry I had Linux server in mind.. and obviously the ps 1.5 versions were in a php 5.x .. what I was meaning to say is that, we upgraded ps 1.5 sites to tb 1.1 with minimal problem.. and obviously the server has to be switch to php7 too..

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...