Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

jmeca

Carriercompare always Retrieving information...

Recommended Posts

Installed the carriercompare module and is always looking for information does not show results

Any help, please?

https://luzmayor.com/carrito

Share this post


Link to post
Share on other sites

More info needed.  What carriers do you have set up?  Do you get shipping data like prices in checkout? I can find a lot of data on how it is used.  Did you use it in the old ps 1.6?  I looked here on GitHub I don't see any issues logged against the module. https://github.com/thirtybees/carriercompare even the old PS module has on one issue.  https://github.com/PrestaShop/carriercompare/

Share this post


Link to post
Share on other sites
16 hours ago, Factor said:

More info needed.  What carriers do you have set up?  Do you get shipping data like prices in checkout? I can find a lot of data on how it is used.  Did you use it in the old ps 1.6?  I looked here on GitHub I don't see any issues logged against the module. https://github.com/thirtybees/carriercompare even the old PS module has on one issue.  https://github.com/PrestaShop/carriercompare/

Hi. Thanks for your help. If I have the transporters already created. I have downloaded it from here

https://github.com/thirtybees/carriercompare

In the shopping cart do not appear shipping costs as shown in the image

 

Screenshot_2019-09-23 Transportistas • Meyvaser cb.png

Screenshot_2019-09-23 Carrito - Meyvaser cb.png

Share this post


Link to post
Share on other sites
42 minutes ago, jmeca said:

Hi. Thanks for your help. If I have the transporters already created. I have downloaded it from here

https://github.com/thirtybees/carriercompare

In the shopping cart do not appear shipping costs as shown in the image

 

Screenshot_2019-09-23 Transportistas • Meyvaser cb.png

Screenshot_2019-09-23 Carrito - Meyvaser cb.png

I have multishop too

Share this post


Link to post
Share on other sites

You have all the ranges setup? In the carrier section?  You also put in a address and post code in checkout?

Edited by Factor

Share this post


Link to post
Share on other sites

Enable error reporting, the module is spitting out an error it looks like. 

Share this post


Link to post
Share on other sites
14 hours ago, jmeca said:

In the shopping cart do not appear shipping costs as shown in the image

What happens further through the checkout process, on step #4 where carriers are usually chosen? Do all the different carriers show up there properly? Can you post a screenshot of that?

Share this post


Link to post
Share on other sites
7 hours ago, Factor said:

You have all the ranges setup? In the carrier section?  You also put in a address and post code in checkout?

Yes of course

Share this post


Link to post
Share on other sites
9 hours ago, dynambee said:

What happens further through the checkout process, on step #4 where carriers are usually chosen? Do all the different carriers show up there properly? Can you post a screenshot of that?

I think it's ok

Screenshot_2019-09-24 Carrito - Meyvaser cb.png

Share this post


Link to post
Share on other sites
1 hour ago, jmeca said:

I think it's ok

Looks like the carriers themselves are set up then so for some reason the module isn't working correctly.

The next step is what @lesley said, enable error reporting so it is possible to see what is causing the module to fail.

Share this post


Link to post
Share on other sites

Its showing an error in the console, I think the module will need some changes to be compatible with 1.1.x

Share this post


Link to post
Share on other sites

Nobody. You have to check your server logs and find actual error message. Then we can help you

Share this post


Link to post
Share on other sites

This is i can see in thirtybees logs:

*ERROR*     2019/10/25 - 08:50:49: Property Address->postcode is empty at line 1036 in file classes/ObjectModel.php
*ERROR*     2019/10/25 - 08:51:03: Property Address->phone_mobile is empty at line 1036 in file classes/ObjectModel.php
*ERROR*     2019/10/25 - 08:52:00: Property Address->postcode is empty at line 1036 in file classes/ObjectModel.php
*ERROR*     2019/10/25 - 08:52:13: Property Address->phone_mobile is empty at line 1036 in file classes/ObjectModel.php
 and server logs:

"POST /modules/carriercompare/ajax.php?rand=1571995250129 HTTP/1.1" 500 27623 "https://ventaregalo.com/carrito" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0"

I have php 7.3 centos 7 in server

Edited by jmeca

Share this post


Link to post
Share on other sites

You can do this:

  1. enable debug mode
  2. open javascript console
  3. click to Networks tab
  4. Find 500 post request and click on it
  5. click on Preview
  6. tell us what the page says

image.thumb.png.5108f6e0135d0c6a4923f5e81a8f7b2a.png

Share this post


Link to post
Share on other sites

Strange, I can see the error code clearly:

image.png.b5e3adf87062af9a0eb2abb4c49724b0.png

Anyway, the problem is this: 

The module tries to create temp/dummy address in order to calculate shipping cost to that address. Because ajax request didn't provided any zipcode:

image.png.b9fe36e533fefb6c7d2cd69fa0517174.png

module ends up trying to create address with empty postcode, resulting in this error code.

The best way to fix this is to modify php code and properly handle the situation when no postcode is provided. Alternatively, you can modify javascript code and pass some dummy zipcode, when none was entered yet. 

Share this post


Link to post
Share on other sites

Thank you very much for your help and interest in helping me.

I'm quite scarce in programming and I don't know how to do what you propose.

If you think you can fix it, we can fix an amount to solve it, if your time allows?

Share this post


Link to post
Share on other sites

I offer few paid support packages. The minimum is 2-hour support. 

To fix issue like this would take just a couple of minutes (~20mins). You could use the rest of the time on other issues/bugs, of course. It's valid for 1 year

Share this post


Link to post
Share on other sites
On 10/25/2019 at 4:44 PM, datakick said:

I offer few paid support packages. The minimum is 2-hour support. 

To fix issue like this would take just a couple of minutes (~20mins). You could use the rest of the time on other issues/bugs, of course. It's valid for 1 year

I prefer to buy your One page chekout module, think is nice, only two questions:

is ready for multishops?

Have it spanish translations?

Thank you very much for your help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...