Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Wartin

403 forbidden when translating email templates

Recommended Posts

I'm trying to translate the emails to Spanish. It shows me html and txt versions of the templates, but when I try to Save, it says:

Forbidden

You don't have permission to access this resource.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

 

/mails/es/* has 644 permissions,  /mails/es 755. I don't know if thats OK, but it didn't work even with 666 and 777.

 

Thank you!

Share this post


Link to post
Share on other sites

Using 777 permissions is always kind of conceding defeat. Much better is to find out and understand what's going on.

One thing to check would be ownership, user and group of these templates. They should match the user running PHP, often 'www-data'.

BTW., what are you using to edit these templates? I usually do this manually, via SSH or FTP and with a plain text editor. Probably not must user friendly, but it works.

Share this post


Link to post
Share on other sites

If you are on a shared host and using Apache webserver, try to disable mod_security.

Share this post


Link to post
Share on other sites
On 5/10/2020 at 11:10 AM, Traumflug said:

One thing to check would be ownership, user and group of these templates. They should match the user running PHP, often 'www-data'.

BTW., what are you using to edit these templates? I usually do this manually, via SSH or FTP and with a plain text editor. Probably not must user friendly, but it works.

Hello. In effect, the owner of those files is the user that runs apache, in my case the user the hosting gave me. I just tried for a second 666 and 777 to see if it worked, but didn't.

I'm trying to change the templates from backoffice's web interface, it's pretty and easy, from Localization -> Translations -> E-mail templates. It gives you a wisywyg editor. For sure I can do it using Vi :)  (maybe it's the best option)

Thank you!

Share this post


Link to post
Share on other sites

Does your theme provide templates? In /themes/<theme>/mails/... These override templates in core (and are the preferred way to use custom templates).

Share this post


Link to post
Share on other sites
4 hours ago, Traumflug said:

Does your theme provide templates? In /themes/<theme>/mails/... These override templates in core (and are the preferred way to use custom templates).

I'm using Niara, it doesn't have a mail directory. I found a weird thing, though, it existed the directory /themes/Niara (with capital N). Inside, just 'mails' directory.

I deleted that directory without success. I finished editing manually the templates under /mails/es using ssh and an editor.

I see some others strange things, in Localization Front office has several untranslated strings, but in a fresh installation there are none.

Share this post


Link to post
Share on other sites
On 5/10/2020 at 1:08 PM, yaniv14 said:

If you are on a shared host and using Apache webserver, try to disable mod_security.

I finally could understand your answer. That was the problem. I had the same 403 forbidden error when adding SQL queries.
It is a shared host, so I logged in to cPanel and search for 'security'. After disabling Mod security I could create my query, and then i activate it again.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...