Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

haylau

[SOLVED] javascript in CMS?

Recommended Posts

Hi

 

Trying to add some code to CMS page, but it is being stripped.  I am trying to embed a clickable link to the Tawk.to chat system so I can disable the pop up widget (https://help.tawk.to/article/using-a-text-link-or-button)

The code is: 

<a href="javascript:void(Tawk_API.toggle())"> Click to Chat </a>

I have switched to source code view and paste that and save, but it is changed to 

<a> Click to Chat </a>

I read somewhere that it could be to do with tinymce and made some mods (https://mypresta.eu/en/art/prestashop-16/extended-rich-text-editor.html)

But that does not help either

Any ideas?

Share this post


Link to post
Share on other sites
34 minutes ago, Traumflug said:

HTMLPurifier turned off in Preferences -> General?

It is off, is that how it should be?

 

Share this post


Link to post
Share on other sites

Not a perfect solution, but pasting the code directly in to the database works

Share this post


Link to post
Share on other sites

Hi, I have the same problem, with HTMLPurifier turned off the page still just says "The content field is invalid" when I try to paste in Javascript (trying to embed a Paypal subscription button in a CMS page).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...