Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Websprint

(solved) Core updater issue (ajax error in fresh install)

Question

I've installed new Thirtybees 1.3 for testing new functions. First issue that I found -  issues in core updater (last versions 1.4 - 1.4.3). 
When I try to check for updates - core updater working and found that my fresh installation are corrupted! 😮 and ask to fix it (screenhort #1).
In next step - Ajax request failed ..(screeshot #2)
Also ajax issues was founded in some third-side modules, that worked fine in 1.2 (like Elementor)
I've tried change php versions 7.2 - 7.4 but no changes.
 

2021-10-20_155524.png

2021-10-20_164353.png

Edited by Websprint
case solved

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The ajax problem will be, most likely, caused by mixing http and https. Browser might block ajax requests from http to https. Make sure you are logged in to your back office using https:// protocol, and then try update again.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks Petr! Youre idea was correct, but the opposite in my case 🙂 - when I using httpS in backoffice - all ajax requests not working, instead - if use just http - everythihg work fine! ))
Maybe I have some SSL problem on server, but now is not matter, because updater and  other modules, that using ajax works in not-SSL mode in backoffice. 
[SOLVED]

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, datakick said:

The ajax problem will be, most likely, caused by mixing http and https. Browser might block ajax requests from http to https. Make sure you are logged in to your back office using https:// protocol, and then try update again.

You are absolutely right - mix content! But problem present in the core updater module and maybe in the core. Because if we have TB 1.2 and httpS - everything works fine. If system updated to 1.3 (it only possible in non-SSL http mode), then mixcontent appear in various backoffice modules, which can't working anymore under httpS mode. I think it would be good idea to put this case as system issue

mixcontent.png.0729dee25db3bc0274e8b6e3ccaef9df.png

mixcontent0.png.1830c894263eb911491fc2768de375fc.png.

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, datakick said:

do you have ssl option enabled in settings?

Ups.. - nope! 
My unattention (( 
Now I switch it on and everything working absolutelly correct. 
Thank you sooooooo much!
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...