Issue after upgrading to php 7



  • Today I upgraded VPS server to Debian 9.0, php 7.0.19 and mariadb 10.1.23. After this I have a error:

    Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/tb/public_html/vendor/symfony/polyfill-mbstring/Mbstring.php on line 420
    

    Back-office works OK. The store was running smoothly on php 5.6. I’m using the theme from prestacrea (currently they offer only version for PS 1.7).


  • Global Moderator

    Symfony and PS 1.7 theme. This looks like a Prestashop install, not a thirty bees install. Wrong forum?



  • No. I’m using TB 1.0.1 with theme sportfitness v1.1.6. Before upgrade php front office worked properly.


  • Global Moderator

    Ah, yes, sorry, I forgot about that one symfony package used by thirty bees and your comment about PS 1.7 themes confused me.

    Did you have have an override for PHP max_execution_time in your 5.6 php.ini? If yes maybe this override is missing in your 7.0 php.ini?

    30 seconds is the default value.


  • administrators

    Still 30 seconds is pretty slow. We have made thirty bees a lot faster than that. Is there a slow module perhaps?



  • @mdekker
    I’m using the default TB 1.0.1 installation, there are no external modules. This is test VPS server.

    Could you look at the store configuration? I can send you BO and FTP access data in PM.

    I am faced with a difficult choice - use php 5.6 or 7.0


  • administrators

    Yeah, sure. You can send it over.

    Often different PHP versions have their own configuration, so could be some extreme value that’s causing it indeed.


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.