Installation in Spanish is stopped in 75%



  • Well that’s what I can not install, I do not know if it’s because it’s in Spanish or why, always stop at 75% put the following
    Ajax request failed for process installModules = true with error.
    Service Unavailable

    Attached image
    Pd: Sorry for my English, I use google translate

    https://drive.google.com/file/d/0B67eoATSRGuuRVFOWGFhUlVFcFE


  • administrators

    Does the installation work for you in english?



  • @josraso Does the install work in English?



  • I’ve encountered similar problem just few days ago - it was caused by low fastcgi_read_timeout settings in my nginx configuration. Apparantly 90 seconds isn’t good enough. I increased it to 360s and it went well.

    I guess it would be beneficial to split the installModules phase to several separate steps.


  • administrators

    We will have to figure something out about that one. What it does is download the translations from the Crowdin api, so that might be what is holding things up. MAybe we can cache them in an earlier step or something.


  • Global Moderator

    It’s a hard problem, you have:
    PHP installation has max_execution_time (default 30)
    Nginx fastcgi_read_timeout (default 60)
    Apache Timeout/ProxyTimeout (default 60)

    Then the PHP code may go on doing something really long-running (like loading the database or resizing images).
    Or something that blocks on an external resource (like a HTTP request to a dead or slow host)

    How to handle this mess in a good way, so it always either works or gives a meaningful error message when it doesn’t?
    And even worse when it’s an AJAX-request triggering the above…


  • administrators

    Yes, it is. I am sure we can find some way out of the box though.


  • Global Moderator

    How to handle this mess in a good way, so it always either works or gives a meaningful error message when it doesn’t?

    A long term solution is certainly to do not one Ajax request for all modules, but one such request for each one module.

    To solve the problem at hand … it’s a bit of a guess right now, but I think it works to save a list of all folders in modules/, then to remove all these module folders, except tbupdater, before starting the installation. Can be done via shell or via FTP. Then start the installation, the module installation step should finish pretty quickly.

    This bare-bones installation should basically work, even with the shop front page being almost empty, no admin dashboard, etc. Then one can install all the modules the usual way, one by one, in Backoffice. It’s not even necessary to restore all the module folders.


  • administrators

    It could be the image generation too. With the new fixtures I have them packaged to create the images at install. I should fix that in the next version.



  • @roband7 one possible solution is to detach php process from request - installModule will immediately return response, but php process will continue to work (this is basically the same way cron works). There would have to be some javascript on frontend that would periodically check if the process finished yet.



  • Well if I install in English it installs perfectly, I have also tried to install the version thirty bees 1.0.1 in Spanish and the installation is completed perfectly, I already tried the Options that comment and always stops in 75%, so I will have to Wait to be able to try this new application.


  • administrators

    I will add this to our bug list, but you can also install it and switch to spanish after the fact.

    At the same time, where are you hosted and what package do you have? It would benefit us to test the fix out on that.



  • It’s not only the modules (similar problem currently with PS 1.7.2 btw). When I tried to upgrade my test installation from 1.01 to 1.0.2, thirty bees install hang when trying to backup. The upgrade could only be completed successfully after I disabled the backup.



  • the problem is same for thirtybees in a new version 1.0.3 when i tried installing in cloudways manually. here i attached the screenshoot.

    http://nimb.ws/o7c2qz

    Best Regards


  • administrators

    You posted a link people cannot see.



  • hi
    related issue in my site
    my version 1.2 the version tbupdater something problem with tb updater admin panel loading very very slow. updater deleted no issue speed good . and i use 1.1 updater not loading issue speed fine
    and i try to update each updater 1.1 and 1.2 not connect channel see blow
    Your current thirty bees version: 1.0.2
    Are you ready to update thirty bees?
    IT IS UPDATENOW BUTTON i click hiar
    Going to update to thirty bees version: Not available
    Channel:



  • This is definitely timeout-related issue. When installed TB (with Russian language) for the first time, on clean environment, i’ve got no issues.

    My php/nginx config includes long timeouts - 600 sec, or even 1200. I figured out that values when updated a lot of images.



  • @ daokakao thanka for your reply . how to solve this please say proper server settings and help me



  • You have to examine your php and webserver config.
    …/fpm/php.ini
    max_execution_time = 600
    max_input_time = 600
    default_socket_timeout = 600

    nginx.conf:
    send_timeout 600s;
    fastcgi_send_timeout 600s;
    fastcgi_read_timeout 600s;

    php-fpm.conf:
    server unix:/run/php/php7.0-fpm.sock weight=1 fail_timeout=600s;



  • thanks for your answer daoKakao
    my php v 7.1
    server apache nginx with using cloudflare cdn ok i try now
    special thaks


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.