I've updated thirty bees from 1.0.1 to 1.0.2



  • Hi all,

    First I’ve made the migration from Prestashop 1.6 to thirty bees 1.0.1. And every thing was ok, but when I’ve made the update I didn’t have errors. When I try to generate pdf invoice from Order -> Invoices it doesn’t work. I have the following error:
    Argument 1 passed to HTMLTemplateInvoiceCore::__construct() must be an instance of OrderInvoice, instance of OrderInvoiceCore given, called in /var/www/html/public_html/classes/pdf/PDF.php on line 151
    at line 54 in file classes/pdf/HTMLTemplateInvoice.php



  • You will need to wait for v1.0.3 or grab all the changes made after v1.0.2 from the github repo.
    There are plenty of fixes since v1.0.2 and I am sure that one of them is for your issue.



  • Do you have any idea when will be the next version release, or can you give me a link to v1.0.2 from the github repo



  • Can tell about release date.
    Here is thirtybees github repo.

    https://github.com/thirtybees/thirtybees

    whatever you see the latest, so check relevant commits to you and just grab whatever you need.



  • Thank you!


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.