Wanted to play around with an Install and this happened...



  • Create settings.inc file
    Create database tables
    SQL error on query Unknown storage engine 'ENGINE_TYPE’
    An error occurred during installation…
    You can use the links on the left column to go back to the previous steps, or restart the installation process by clicking here.



  • It did not happen to me when I did my installation on local server as well as online server. everything went on smoothly. maybe the installation file you downloaded is not complete?



  • I tried this on 000webhost and it said it met all requirements. Maybe I’ll try my paid host tomorrow and see if I have different results.
    Edit
    Also is there a demo link anywhere



  • i would suggest you download the installation file again. It should not be an issue from hosting.



  • I redownloaded and tried my other host and how I cant even get to the install page. I am currently using prestashop so I have no idea why it is not working. Like I feel like there is no reason it should not be working.

    Edit: Found what was causing the error. Will update again once it installs.

    Edit2: Got it working on a different host. I am sure 000webhost did not meet one of the requirements some how and thats why it did not work.


  • administrators

    Wierd. It’s just amazing what webhosts can mess up on a system. Thanks for posting here. We’ll investigate this to improve the installer.
    We might/might not be able to detect this, but have a look at it anyway.


  • administrators

    Turned into a GitHub issue: https://github.com/thirtybees/ThirtyBees/issues/135

    That’s for our long list of reminders so we don’t forget.



  • @mdekker my issue with my paid host was uploading the zip file and using their built in extractor. Could be a similar to 000webhost if you want me to test uploading all files via FTP


  • administrators

    Doesn’t matter, still going to investigate. If that’s the cause the installer should be able to explain what’s going on.


  • administrators

    Ahh, yeah, I found the problem. 000webhost immediately presents you with an uploader. It makes you think you can upload all files at once by just selecting them in the file browser, but folders and their contents are actually not uploaded. It is also not possible to upload the whole zip first and then unpack.

    What you should do is just skip the introduction screen and navigate to “Settings > General” and use the FTP credentials to upload all files via FTP.



  • I have the same problem during installation.
    Wich files I must upload via FTP?
    Where can I find these files?


  • administrators

    You can download them from here, https://thirtybees.com/download/ or you can also launch a free trial store from there as well and you do not have to install anything.


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.