Minor comment for upgrade module



  • I downloaded the Upgrade module from github and had some minor issues installing it. The error message was not 100% clear but basically it came down to that having a name of the zipfile such as tbupdater-x.y.z.zip was not liked by Prestashop. However the culprit was that the folder was still created and that caused additional confusion.

    I had to unzip the tbupdater-x.y.z.zip rename the folder to just tbupdater and the recompress it again so the folder name did not include the - and the version. Then the module installed ok.

    Maybe not using the version tag in the folder name for the github zip could save some time for the next guy downloading the module.



  • AFAIK, these downloadable files on Github are auto-generated, so developers have no influence on how they’re named. One of the many oddities of Github.



  • Then I guess it would have to be solved in the application side.

    This is really not a big deal, I am marking as solved and leaving it as a reference if someone else has the same problem in the future.



  • @hubbobubbo
    If I understand correctly from the first comment, was an attempt to use tbupdater in a Prestashop installation.

    Of course, this does not work…



  • @zimmer-media Sorry for not being clear. It was when installing tbupdater from a TB installation (I had already migrated to 1.0.1 and wanted to update to 1.0.3)



  • @hubbobubbo
    ah - ok
    i am not a programmer, but have you tryed the previous tbupdater 1.2.2. - udate to tb 1.0.2. then to 1.0.3?



  • Use the releases tab if you download from GitHub, otherwise you will download the sources, often without the dependencies.


 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.