Request for help with Thirty Bees Vagrant on Windows



  • Hi,

    I’ve read your blog for installing the Oracle Virtual Box, installing Vagrant and installing GIT. I’ve managed to do the git clone from the thirtybees/vagrant (I also put the ip address 10.0.0.30 suggested in my hosts file) but when I run vagrant up nothing happens, it just sits there.

    Is there a step I’m missing to make this work? I’ve got the oracle virtual box tool running but haven’t set up a virtual box space, is one needed and if so what should the settings be?

    I’ve tried pinging thirty.bees and it does recognise it on ip 10.0.0.30 but it’s coming back as request timed out. I’ve also tried an ipconfig /flushdns to see if that helps.

    Running ‘vagrant global-status’ states there’s not Vagrant environments on this computer. I thought the thirtybees was the environment? The files are there in the playbooks area so something has come across from github.

    I’m sorry if this all sounds basic to you but I’m coming from a WAMP background experience so this is very new to me.

    Thanks,
    David


  • administrators

    I can’t launch an instance either anymore. You can revert a few commits and find a working version then. The latest changes by @dprophitjr seem to have broken it.



  • @mdekker least it’s not me then :)

    I think there’s some other issue going on for me as well as I’m working through tutorials for the virtual environment and it’s doing the same thing. I think there’s a disconnect between vagrant and the virtual box somewhere on my machine, even after rebooting it and checking paths.


  • administrators

    Vagrant connects to the box via SSH. If you see some early messages about it not being able to connect via SSH, then it could be disconnected indeed, but AFAIK the Ubuntu image always has the default vagrant/vagrant user pass combo.



  • It seems the issue might be down to vagrant 1.9.7+ not working with Windows 7 powershell below version 5 and needing to upgrade that; the latest Vagrant I downloaded was 1.9.8. I maybe should have said Windows 7.

    I’m on version 2 of the Powershell (my computer doesn’t get updated much and is on the default) and the minimum version vagrant will work with is version 3! Some people had suggested killing off the powershell processes but that doesn’t work. It’s also recommended that you upgrade to version 5 to make it work but you’ve got to upgrade to 4 before 5, you can’t just jump to 5…

    feels like trying to get WAMP to work lol!



  • @mdekker after reading up that I need Windows Management Framework 5.1 to get PowerShell 5 and have to jump through hoops to make the WMF work on Windows 7 I’m going to ditch trying to use Vagrant due to the risk of upgrading my computer. Looks like I’ll go back to trying WAMP.


  • administrators

    Have you considered running Ubuntu from a stick? Most of us tend to work with it here, so we can help any issues with it normally.



  • @lesley I just got my company to get another shared server package for £2.99 a month, lot less hassle :)


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.