Can't add category as sub



  • When I create category and try to add the new category as sub, I can’t expand the categories list which makes me able to add it just under home category.
    It is fresh 1.0.3 install without demo products, tried on IE and chrome. Any suggestions are welcome!



  • In chrome check your console log for errors



  • May I give you back office credentials and check it yourself :)



  • ok



  • is it a clean install?
    did you delete any categories from the db?



  • I installed it today, installed the template, tried some performance caching options, uninstalled some modules. That’s it.



  • i changed the tb-admin theme to another and its works



  • Did you met the same issue?



  • @mockob
    yes, but i dont know more on wich store - i have more, and in one i cant expand/collapse etc the category-list with tb-admin-template - i changed to another admin-template for example prune, flex or fruit and it works without problems



  • Just made clean 1.0.3 install with demo products like @yaniv14 suggested. Tried to add sub category and the category tree expanded as it should. Then I used the TB cleaner and added another sub category. Then uninstalled all unnecessary modules and added the custom template (without switching to it). Now again I can’t add sub category because the category tree just doesn’t expand.
    @zimmer-media also tried your trick without any success :(



  • First of all I want to thank @yaniv14 for the time spent on my test shop!
    I just made clean install of thirty bees 1.0.3 without demo products. Changed the view of the back end theme and added a directory called new1. After that on the main category menu I am able to see Home category (which I don’t usually see) and when I try to add another category and make it sub, I can’t expand the tree.
    Those are all the steps I did, so if anyone has any suggestions is welcome! I can’t believe I am the only one experiencing that issue, it is at least 4 clean instalations with or without demo products and same behavior every time. If anyone believes can help with solving the issue please write me message to give you access to the server and backoffice!
    Here are pictures with the home category listed and the “expanded” category tree.
    0_1504508950567_categories.jpg
    0_1504508965723_theexpandedtree.jpg



  • @MockoB I think I located the bug.
    When there are no categories at all, if you click on the expend all button if will get broken ajax result, which cause the bug the you are experiencing, due to the fact that the return ajax result will change the category tree input name from id_parent to something else and because of that the controller will create a root category instead of regular category with Home as parent.
    Basically if you work as usual and won’t click the expend button (before adding a single category) you should be fine.



  • I actually clicked the expand button before I added the new category I think. I will try again to add some categories later and check how it will behave. I am thinking that it’s just me who is starting shop from scratch and everyone else are adding categories and products through bulk import…



  • I can confirm its a bug.
    The only thing you need to do to avoid that bug (until its officially fixed) is to NOT click the expend all button before you have at least one category (anyway you don’t need to click this button with 0 categories because it won’t expend anything)



  • Thank you very much once again!



  • i just successfully added 27 categories. Thank you!



  • @MockoB @yaniv14 has been a life saver more than once! :)
    Thank you!


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.