Issue with more than 1 custom payment methods



  • When using custom payment methods and configure more than 1 method, one can select which of the custom payment methods can be shown for which shipping carrier. However even I set not to display for a certain carrier, it will still be displayed. Furthermore the payment image is messed up in that the same image will be shown for the 2 different payment methods when doing checkout. Not sure if this is a known issue.

    Thanks and regards,
    Tin Ho



  • This post is deleted!


  • @tinho-chan said in Issue with more than 1 custom payment methods:

    When using custom payment methods and configure more than 1 method, one can select which of the custom payment methods can be shown for which shipping carrier. However even I set not to display for a certain carrier, it will still be displayed. Furthermore the payment image is messed up in that the same image will be shown for the 2 different payment methods when doing checkout. Not sure if this is a known issue.

    Thanks and regards,
    Tin Ho

    Yes i have that Error on my Site too.
    Im using 2 different Images but it shows 1 Image on both Payment methods.
    Same with the Description 😯



  • @alwayspaws , i installed this module through Thirty Bees admin back office. Not sure what you mean by seeing anything different.



  • This post is deleted!


  • @alwayspaws , this is just the config screen of the module. adding new payment method is through another menu item which is newly available after you installed the module. did you go to “Modules and Services -> Custom Payment Methods”? from there it is to add at least more than 1 payment method and i get the issue that i mentioned in the 1st post.



  • I did go there and I was right back to the screen that I showed you. In any case I don’t need this but I’ll watch it. I did this so you would get attention to your post.



  • Thanks for the report. We have taken care of both issues with version 1.2.0. It should be available in your back office.



  • I assume you refer to the module version of the custom payment method. I just tested the latest 1.2.1 and hit two issues:

    • If I set more than one custom payment method, then I do not see any of the custom payment methods during checkout. There is a big box I can select and after confirming the order it just go to another screen with nothing and the order still in the cart.
    • In back office I created 3 custom payment methods, then delete 1, then add a new one again, the thumbnail of the new custom payment method shows the one from the deleted custom payment method. Even I uninstalled the module and re-installed, after creating new custom payment methods, old thumbnails are shown.

  • Banned

    This post is deleted!

  • Banned

    This post is deleted!

 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.