Prestools suite - compatibility with thirty bees



  • @occam said in How to edit the carrier of an existing order?:

    @30knees Just install musicmaster’s awesome free Prestools suite and you are able to edit much more than just the carrier.

    Following a tip from @Occam, I installed the Prestools suite. I tried to install the mini-module prestoolssuite-module.zip but got this error:

    [ThirtyBeesException]
    
    Property Tab->name is empty
    at line 1071 in file classes/ObjectModel.php
    
    1066.                 }
    1067. 
    1068.                 $message = $this->validateField($field, $value, $idLang);
    1069.                 if ($message !== true) {
    1070.                     if ($die) {
    1071.                         throw new PrestaShopException($message);
    1072.                     }
    1073. 
    1074.                     return $errorReturn ? $message : false;
    1075.                 }
    1076.             }
    
    ObjectModelCore->validateFieldsLang - [line 373 - classes/ObjectModel.php]
    ObjectModelCore->getFieldsLang - [line 610 - classes/ObjectModel.php]
    ObjectModelCore->add - [line 529 - classes/Tab.php] - [2 Arguments]
    TabCore->add - [line 56 - modules/prestoolssuite/prestoolssuite.php]
    PrestoolsSuite->install - [line 1643 - controllers/admin/AdminModulesController.php]
    AdminModulesControllerCore->postProcessCallback - [line 1506 - controllers/admin/AdminModulesController.php]
    AdminModulesControllerCore->postProcess - [line 355 - classes/controller/Controller.php]
    ControllerCore->run - [line 743 - classes/Dispatcher.php]
    DispatcherCore->dispatch - [line 63 - admin/index.php]
    

    Has anyone else tried to install and run the module or would know how to fix it?



  • No idea what happens, maybe it’s the dispatcher. I installed this module before upgrading to 1.0.2. You may add the line
    Tools::getValue(‘controller’);
    to this function to force a message which controller causes this error. Or ask the developer @musicmaster himself. He is a member of this forum.



  • Just for the record: You are sure that you uploaded Prestools Suite to a subdirectory of your admin directory?
    The only thing the module does is providing a new tab to open quickly the tools and opportunity to store username and password.



  • @occam The strange thing is that my subdirectory is called administrator, not admin:

    0_1506841051022_7a74bdaa-6214-46be-b088-ef258a05f21f-image.png



  • you can rename it in any name you want.



  • Hi,

    I tried it on TB 1.03 and everything worked ok. What version of TB are you using?

    Also: what operating system has your server? I just filed an error report because the TB module install under Windows doesn’t work correctly - although that has different symptoms and isn’t fatal.

    @Occam: this is a problem with the minimodule that adds an entry to the 30bees backoffice. It is not a problem of the main program.

    Regards,
    M



  • Then it must be something with my installation. I’m also using 1.0.3 and the server OS is Linux.


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.