Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

wakabayashi

Advanced Search 4 - Has errors

Recommended Posts

The popular filter module "Advanced Search 4" from Presta-Module has issues. For me it doesn't save filter ranges anymore. I haven't had this issue, before.

Anybody else using this module?

Share this post


Link to post
Share on other sites

Check the latest version of the module, they seem to have fixed the bug:

https://www.presta-module.com/en/3-prestashop-addons/6-merchandising/7-advanced-search-4.html

Share this post


Link to post
Share on other sites

Consider asking them if they want to support thirty bees as well. I have had a few talks with them, but nothing for sure yet.

Share this post


Link to post
Share on other sites

I asked them about the problem. They gave me this answer:

It's seems that ThirtyBees have made some modifications that set the id_lang as the array of language and do not use it as PrestaShop does.

But they fixed it for me...

Share this post


Link to post
Share on other sites

@Baarssen yeah but they just fixed it for my personal use. So if you have same problems, you should write to the support.

I am exciting for the new elasticsearch module. I hope it will even be better then advancedsearch4.

Share this post


Link to post
Share on other sites

They are a company I would like to see support us, especially since they just bought businesstech last month.

Share this post


Link to post
Share on other sites
On 10/19/2017 at 5:58 PM, wakabayashi said:

@Baarssen yeah but they just fixed it for my personal use. So if you have same problems, you should write to the support.

I am exciting for the new elasticsearch module. I hope it will even be better then advancedsearch4.

Hi

I know this is an old topic. However, we're currently considering Advanced Search 4 for our TB 1.1.0 store and need to check compatibility.
Are you still using it on your store? Do you know if it's compatible with TB 1.1.0?

Thanks in advance.

Share this post


Link to post
Share on other sites
20 minutes ago, haylau said:

We are currently using it without issues 

Thank you. On which version? TB 1.1.0 and latest Advanced Search 4 - V 4.12.9? 

Share this post


Link to post
Share on other sites
18 hours ago, haylau said:

Advanced Search 4 v4.12.5

TB 1.1

Thank you

Share this post


Link to post
Share on other sites

Anyone here on TB 1.1.0 with latest Advanced Search 4 v4.12.9?

Share this post


Link to post
Share on other sites

I actually use this : Advanced Search 4 v4.10.16 - by Presta-Module

on a TB 1.0.8 since few month already and having no issue regarding that.

Share this post


Link to post
Share on other sites
2 hours ago, Theo said:

Anyone here on TB 1.1.0 with latest Advanced Search 4 v4.12.9?

I'll try it later. Can't see it being a problem as only minor bug fixes in the latest few releases

Share this post


Link to post
Share on other sites

OK, tested. All seems to be OK. Except when products are filtered the images are missing. This may be an conflict with lazy loading in the theme as I seem to remember this before? We are using Panda.  @Jonny

Share this post


Link to post
Share on other sites
13 hours ago, haylau said:

OK, tested. All seems to be OK. Except when products are filtered the images are missing. This may be an conflict with lazy loading in the theme as I seem to remember this before? We are using Panda.  @Jonny

This is a bit of an issue / deal-breaker then as we're running Panda also...
I'll try the earlier version you suggested (4.12.5)

Unless, someone here has the Panda fix? @Jonny

 

Share this post


Link to post
Share on other sites

It is definitely the lazy load on the category section of the theme. Disable that and all is well. 

Share this post


Link to post
Share on other sites
On 11/13/2019 at 9:33 AM, haylau said:

It is definitely the lazy load on the category section of the theme. Disable that and all is well. 

Good to know, however lazy load is critical in improving page load speed (plus it looks cool) - so it needs to be sorted somehow before we can go 4.12.9.

I don't suppose any one here know the fix for the Lazy loading issue? @Jonny

Edited by Theo

Share this post


Link to post
Share on other sites
On 11/13/2019 at 9:33 AM, haylau said:

It is definitely the lazy load on the category section of the theme. Disable that and all is well. 

Hi Haylu

Panda / ST Theme has a solution - I think prompted by your original post of the ST Forums.
https://www.sunnytoo.com/forums/topic/lazy-load-of-images

Solution:

https://www.sunnytoo.com/13194/integrate-advanced-search-4-module-work-transformer-theme-panda-theme

As I have as yet to install Advanced Search 4 - please may I ask you try to see if these instructions still work on your latest version?

Edited by Theo

Share this post


Link to post
Share on other sites

That solution works for the latest version of A4. Don't worry about compatibility issues with A4, let me know if you find any, I will help you fix them.

Edited by Jonny
  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, Jonny said:

That solution works for the latest version of A4. If you have problems of using A4 with Panda theme, just let know I will help.

Perfect, thank you

Share this post


Link to post
Share on other sites

Confirmed - this works. Just be careful not to start at the top and work down like I have just done - because the first bit is about Prestashop 1.7

Skip to this section: 

Integrate Advanced search 4 module with Transformer theme v3 and Panda theme v1

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...