Setting up a dev/test instance



  • I migrated my shop from prestashop. Now I’m trying to create a dev instance to test updates, etc prior to updating the production store. When I go through my typical way as listed here https://www.prestashop.com/en/blog/set-up-a-test-server-for-your-online-store, I get this error. Link to database cannot be established: SQLSTATE[HY000] [1045] Access denied for user ‘<mycpaneluserforthedb’@'localhost>’ (using password: YES)

    I’ve never had this problem with prestashop prior. Is there something else I should be doing with Thirty Bees?



  • No, this is mysql-related issue.

    1. Check my.cnf - there is an option binding mysql to specific address. Aware that it is bound to localhost
    2. Usually i fire following commands in the mysql console: GRANT ALL PRIVILEGES ON database_name.* TO ‘username’@‘localhost’ identified by ‘new_password_goes_here’;
    3. Don’t forget to fire FLUSH PRIVILEGES; right after command of step #2


  • Check that you db name, db user & db user password are similar to the ones in ‘config/settings.inc.php’



  • @yaniv14 They’re correct



  • @daokakao Appreciate the attempt at helping. But I have no idea what you are talking about.



  • I figured it out…sort of. I had to switch users to the default one created by TB when I created the DB. It wasn’t letting me use any others. It’s working now, regardless.



  • Just before TB install you have 2 cre8 a database. Of course, TB itself can try to do this automatically, but it would be better if you create the database manually.
    I showed needed commands. If you (can) use the phpmyadmin, there’s a tab in it, called SQL, you should open it and insert the text shown above in it. Don’t forget to select appropriate database, then replace database name, username and password with real data and run this sql command. After it completed with success you have to specify the database name, username and password in the installer.


Log in to reply
 

Looks like your connection to thirty bees forum was lost, please wait while we try to reconnect.