Jump to content
thirty bees forum
  • 0

Product pages on 1.0.3 showing error 404 with non friendly urls even when set to use friendly urls



My 1.0.3 install has suddenly stopped using friendly urls, even though it's set in the admin by default. The product 'candle' now gives the url (I took out my domain name): http://#####/index.php?controller=productrule&id=1&rewrite=candle&ean13=0&metakeywords=

This has happened since I enabled the currency switching on my store. However, if I go into the basket, which had products in them already and click the candle from there it goes to the product with the url being: http://#####/gifts/candle#/1-size-12_oz/22-scent-honey

Interestingly, this doesn't have the currency switching available in the menu.

It seems all of my urls are now broken. I tried disabling friendly urls and then re-enabling them, which corrected the urls again and clicking the candle from the home page went to the url: http://#####/gifts/candle

However, this page didn't have the currency selection available on the top menu. Refreshing the page brought the currency selector back and it now seems to stay active. There's also another issue here (another bug?) in that it's not remembering the selected currency through page changes. I set the currency to euro on the product page, switched to the home page and it changed to dollars. I changed it to Euro, went to the product page, selected dollar and going back to the home page it switched to Euro. If I refresh the page it switches to the correct currency selection.

Whilst enabling the currency changing stuff I enabled a new language, set it as the default then disabled the original default. I added a new tax group for this language and allowed two currencies to be available for it. Basically switched to English (GB) from English (US) and had Euro & Dollar for the currencies. I also cleared the cache under peformance after each change.

I know it's a longshot tracking it down but something in my use of multiple currencies broke the friendly urls.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...