Jump to content
thirty bees forum
  • 0

Core Updater 403 Forbidden Error



I just made a fresh install of TB 1.1.0. I've installed a couple of modules and made some minor changes but haven't done anything major to the installation. File permissions are 775 for folders and 664 for files. File ownership is correct. I have reset permissions & ownership multiple times to make sure they are right.

When I go to the Core Updater module and click on Compare (regardless of the options I choose, but let's say Bleeding Edge, 1.1.x, don't ignore community themes) immediately get a 403 forbidden error. It says, You don't have permission to access /admin/index.php on this server.

The address bar contains https://www.mydomain.com/admin/index.php?controller=AdminCoreUpdater&token=tokenremoved

When I do the same thing on one of my dev sites running on the same server with the same settings and the same file permissions everything works fine and I can update the TB installation.

Anyone have any ideas what might be wrong?

Edited by dynambee
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Okay, I figured it out after some more googling. I forgot that the default setup for my server includes mod_security being enabled, which is *generally* a good thing but isn't good for parts of TB.

After disabling it everything works fine. I may try to figure out a configuration that doesn't cause TB to crash or I might just leave it off.

Link to comment
Share on other sites

  • 0

I nuked the above site and reinstalled it again. Fresh clean install but still getting a 403 Forbidden error when I try to use Core Updater.

I have another TB site on the same server where Core Updater is working perfectly.

How can I troubleshoot this? I have tried changing file permissions, reinstalling the site, reinstalling core updater, nothing works. Immediately after I click on the "Compare" button it happens. I have tried Chrome & Firefox, cleared caches, tried restarting the web server... I'm at my wit's end, I can't update the site. 😞


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...