Jump to content
thirty bees forum

Core Updater needs to default to the currently installed version of TB


Recommended Posts

When you first install TB 1.1.0 and then go to Preferences -> Core Updater, if you select "Bleeding Edge" it defaults to version 1.0.x and not to the installed version of 1.1.x. (Once you have done an update once it defaults to the version it has updated at least once.)

If you're a little tired and don't notice this (like I was a short time ago...) and go ahead with the update it will completely bork your store. It deletes the Niara theme but doesn't enable any other theme and of course this results in endless 500 errors when trying to access the front end. Even trying to enable the old community theme once this has happened doesn't seem to work. Recovering the store to 1.1.x might fix it but once a shop is that badly screwed up it's hard to trust that it's going to be okay again. Thankfully it was just a new shop for dev/testing so I just wiped it and started over.

Anyway, the default should be the currently installed version, or if that is impossible then don't default to anything. Displaying an older version as the default in the updater doesn't seem like good UX to me.

Even better, if a store is a new install of 1.1.0 don't provide the downgrade option to 1.0.x at all. If someone really needs 1.0.x they're likely much better off starting with 1.0.8 and upgrading from there. If it can't be removed, some sort of warning & confirmation about the disaster about to be unleashed would be good.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...