Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
ssimard

Modules says that they updated successfully but they did not ?

Question

Hi everyone, trying to update a few modules I had quite a weird bug.

I could update the Google Analytics module properly but the tbupdater and the Dashboard Activity would not update themselves.

For the updater, I simply deleted it physically and reimported it using the latest version, worked fine.

But for the Dashboard Activity, the Back Office confirms that the update worked but the old module is still in place. See pictures (sorry for the french language). Any ideas ? (folders are all 755 right now and I have no write errors in the logs)

0_1507908248471_Capture d’écran 2017-10-13 à 11.19.59.png

0_1507908276304_Capture d’écran 2017-10-13 à 11.20.22.png

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Deleting it and installing the new version worked but I still wonder why the updater was not working.

Share this post


Link to post
Share on other sites
  • 0

Did have the same problem with TB. After renewed login in back office modules where ready to install.

Share this post


Link to post
Share on other sites
  • 0

Update on this:

  1. Did set opcache.revalidate_freq to 0 and restarted Apache. Same problem for every single module updates, says it worked but version did not change and they are still in update needed status. I have 8 modules needing an update now and none will actually update itself even thou the success text is being shown.

  2. Did try to logout and login several times but it did nothing either. I have no cache options enabled at all.

Question: could it be related to file permissions ?

Share this post


Link to post
Share on other sites
  • 0

Yeah I guess the message should at least mention that it failed ;-)

There was nothing in the logs either.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...