Jump to content
thirty bees forum
  • 0

Selecting a new theme copied from the default doesn't work



As the title states, I created a new theme by copying the community-theme-default in the back office and it looks like it's worked – the folder structure has been created and populated with the same files – but when I try to select it nothing happens.

Steps to reproduce:

  1. Preferences > Themes > Add new theme
  2. Scroll to the bottom and click "+ Create a new theme"
  3. Enter names for the theme and the new directory (I used the same name for both, 'ab-theme-1')
  4. Select 'community-theme-default' from the 'copy missing files…' drop-down
  5. Set Responsive to 'Yes'
  6. Click 'Save' and wait for the 'Successful creation' message to appear.
  7. Check the site's themes directory to ensure the new directory has been created and populated.
  8. Mouse over the new theme and click "Use this theme"

The page refreshes but nothing else happens and the current theme doesn't change.

I've turned on debug and worked through the entire procedure again, but no errors are reported. However, although I'm not a developer I figured out (roughly) how to use Firefox's debugger and it seems a whole slew of exceptions are occurring after clicking the 'Use this theme' button.

Is this a bug or am I doing something wrong?

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Okay, I think I've got it working, although it wasn't as straightforward as just copying it. I couldn't install it at first because it had the same name, so I had to rename the original first. Then after installing and selecting it, I went into advanced settings to rename it and noticed it was pointing to the default theme's folder, so changed that too. One odd thing though: I've tried uploading a different preview picture and it states that was successful, but it's still only displaying the default theme's preview picture. So I'm a bit concerned that something's still not quite right.

Link to comment
Share on other sites

  • 0

Ah sorry, I can't tell you now. I restored a home directory backup because even though the website would load after changing the target folder, it had reset all of my module settings. As far as I could tell the folder structure looked the same after making the copy, but I confess I didn't read the error message properly and because I felt sure something had gone wrong in the theme selection process I was thinking of doing a restore anyway.

I haven't had chance to try it again yet but I'm hoping to find some time this afternoon. Is there some reason why that file would have gone missing or gotten corrupted? It seems odd that the problem apparently occurred in the original folder and not the newly copied one, don't you think?

Link to comment
Share on other sites

  • 0

Okay, I've tried it again – several times – and I don't think just copying the default theme and installing the copy is working properly either, or at least not with any of the methods I've tried. Each time, after I've installed it and selected the new folder it's ended up deleting the contents of the original community-theme-default folder and just leaving behind an empty 'docs' folder. I don't know how I missed that yesterday – unless cPanel's file manager was showing a cached version – but that's obviously what led to the site crash.

Now, regardless of whether I'm using an incorrect procedure or not, it just doesn't seem right to me that the theme handling section is deleting stuff without me uninstalling anything. I mean, surely it ought to issue a warning message before doing something so drastic?

Link to comment
Share on other sites

  • 0

I've been looking at this problem again this evening and I've finally figured out how to get what I want: namely, two themes installed and selectable, the default and one based on it.

There is clearly a major bug with the theme handling process, but the steps below got me around it, so I hope it will help anyone else experiencing similar issues until it gets fixed.

Steps to work around the theme handling issue:

  1. Go to the default theme's folder and edit the config.xml file to set enable/disable on the module lists, so it matches up with the current installation.
  2. Copy the default theme's folder and rename it for the new theme
  3. Edit the new folder's config.xml file to replace the theme name and directory in both nodes – <theme> and <variation> – to the new theme's name and folder
  4. Copy the new folder's config.xml file to somewhere outside the folder.
  5. Go to the back office and install the new theme, but do not try to use it yet.
    NOTE: This is where the major issue occurs: it states the upload has been successful, but if you go to the new folder it has been almost emptied out! Just the docs folder remains.
  6. Re-copy the contents back into the new theme's folder and copy the config file back in.
  7. Now you can choose 'Use this theme' in the back office and it should work.

Needless to say, as the settings in these two themes diverge it will be prudent to copy both folders and edit their config.xml files as necessary before switching between them.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...