Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Havouza

php issues I think

Question

I am in the process to move our TB from one VPS to a new one. Both Centos 7. After much troubles I started from scratch and now I think the problem is a wrong php-fpm setting.
I get these two lines in the Apache log. Anyone that can give me a hint what to look for? If necessary I can give ssh access to the server or access to the controlpanel. I would be eternally greatful if someone could help

 

[Thu Apr 25 18:27:07.640875 2019] [proxy:error] [pid 7890] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:8000 (*) failed
[Thu Apr 25 18:27:07.640927 2019] [proxy_fcgi:error] [pid 7890] [client 63.143.42.253:52290] AH01079: failed to make connection to backend: localhost, referer: https://jv74.se

 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Posted (edited)

Hello,

Which version of PHP do you have installed on your VPS?

I prefer nginx, after upgrade to php 7.2 I had to change the entry php5.3-fpm.sock to php7.2-fpm.sock in nginx config file (sites-available directory).

I recommend nginx, along with php-7.2 the store works very fast.

location ~ [^/]\.php(/|$) {

        fastcgi_index index.php;
        include /etc/nginx/fastcgi_params;
        # depending on version, could be : include snippets/fastcgi-php.conf;
        fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

    }

 

Edited by Adik

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Double check this line in your config /etc/apache2/sites-available/...

 <FilesMatch \.php$>
     SetHandler "proxy:unix:/var/run/php/php7.0-fpm.sock|fcgi://localhost/"
    </FilesMatch>

 

Edited by Adik

Share this post


Link to post
Share on other sites
  • 0

I looked at php.ini and it for sure use php 5.4 which I know will not work. but I have no clue how to force 7.0. I use Centos so I cant disable it via ssh as in Ubuntu

Share this post


Link to post
Share on other sites
  • 0

@Havouza Dont you use Plesk or cPanel? It should be easy to change a php version there... Or is the problem much more complicated than I think?

Share this post


Link to post
Share on other sites
  • 0

If I had used Plesk on this new one it would be easy. because we only have one shop left we decided to get a smaller VPS and use Virtualmin instead. All about costs. Pleask has got expensive unfortunately

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×