Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

MichaelEZ

DB migration - 1.0.8 to newest

Recommended Posts

Hi,

I´m trying to export and import products from TB 1.0.8 to 1.1.0 but problem is root category, Im unable to make it work. I tried to export categories via db, then upload it. I can see cat. in backend, but I ´m getting

Root category must be an integer valuein file classes/helper/HelperTreeCategories.php at line 350Source file: classes/helper/HelperTreeCategories.php331:        if (!isset($this->_node_item_template)) {332:            $this->setNodeItemTemplate(static::DEFAULT_NODE_ITEM_TEMPLATE);333:        }334:335:        return $this->_node_item_template;336:    }337:338:    /**339:     * @param int $value340:     *341:     * @return $this342:     * @throws PrestaShopException343:     *344:     * @since 1.0.0345:     * @version 1.0.0 Initial version346:     */347:    public function setRootCategory($value)348:    {349:        if (!Validate::isInt($value)) {350:            throw new PrestaShopException('Root category must be an integer value');351:        }352:353:        $this->_root_category = $value;354:355:        return $this;356:    }357:358:    /**359:     * @return mixed360:     *

Which means root dir is missing. But its not atleast i think

Same happens via store manager, or I can leave old root fold, and edit it - still not working.

1st img from 1.0.8 (exporting) and second is importing one.

image.png.b7bd6042976977f4a48027edd13af6ea.pngimage.png.b8f3c9698ceff750aa7fcbd03adfe707.png

 

Sure why nopt spend XX hours, then write this, when all i had to do is change parental ID od main categories 😄 

// i take that back 😄 its just became subfolder...

Edited by MichaelEZ

Share this post


Link to post
Share on other sites

Uhm, what is the point of doing this? Updating v1.0.8 to v1.1.0 is pretty simple and straightforward.

Share this post


Link to post
Share on other sites

Those are 2 shops, one is old and super slow and full of bugs, second new 1.1.0 clean with new design. It was presta 1.6 week ago, bought module to transfer data to new TB but wastn working. So when i updated presta to TB atleast its little bit faster, but now Im stuck at migrating data to new shop. When i copy table i got missing root dir. I thought store manager work out, but i just find out he changed categories ID.. 

 

When i upload tables its like this : 

pic1   [ AdminCategories&id_category=1&viewcategory              seems like #id1 but thats not root? ]

pic2   [ AdminCategories&id_category=2665          in category it shows "root" ]

pic3   [ AdminCategories default cat page - 24 cat are forbidden  ]

 

cat1.jpg.a433e6a082a16cb090f554be024d772b.jpgcat2.jpg.76dbedcd868c90fe23818356acca0d62.jpgca3.jpg.e0fe300ed05c7b98f3c652856337708a.jpg

 

// Too many hick ups, problems, decided to upgrade on 1.1.0 and try to resolve slow queries problem, somehow 😄 

Edited by MichaelEZ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...