Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Recommended Posts

I have some troubles with MyParcel. We are using version 2.2.1 at the moment.

The problem is that sometimes MyParcel empties the address (just the street and number). The customer has filled them in correctly and they are correctly in the TB_address table. But in the copy of the address in the tb_myparcel_delivery_option table the "street" and "number" fields are left empty sometimes. Postal code and town are always there. Note that the address data are stores in a json structure in the myparcel_delivery_option field. This table has address fields but those are not used (and in the 2.3.6 version removed).

On the basis of just a few samples one possible explanation is that the address2 field is the problem. In all the three failed samples I got this field was filled. In two cases the number was in address2. In the third case the number was in address1 but address2 was filled with "hs". Some comment in the code suggests that the number must be in address1.

The latest MyParcel version is 2.3.6. So I tried to upgrade in the hope that the newer version might have solved the problem. But after the upgrade my backoffice crashes when I want to look at the orders page. I get the error: "Table 'myshop.tb_myparcel_goods_nomenclature' doesn't exist". Some research indicated that when I install the 2.3.6 module over the 2.2.1 module the upgrade files (like Upgrade-2.3.0.php) that should create the extra tables are never executed. 

Things got even stranger when I had a look at a fresh 2.3.6 installation (on Prestashop 1.6) and saw that although the tb_myparcel_goods_nomenclature table is declared in the code it is not created. However, for the rest the database structure is quite different from 2.2.1.

Does anyone here have experience with either this missing address problem or upgrading?

 

 

myparcel-v2.2.1.zip myparcel-v2.3.6.zip

Share this post


Link to post
Share on other sites

Got the same issue sometimes. But in the most of the time I think it is because of a wrong autofill or when the customer puts the housenumber on addres rule 2. Not sure if this is the problem...

Using v2.2.2 

  • Like 1

Share this post


Link to post
Share on other sites
On 12/3/2019 at 9:02 PM, DorkV89 said:

Got the same issue sometimes. But in the most of the time I think it is because of a wrong autofill or when the customer puts the housenumber on addres rule 2. Not sure if this is the problem...

Using v2.2.2 

I ended up upgrading to 2.3.7 - that was recently released. This solved the problems.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...