Jump to content
thirty bees forum
  • 0

Webp issue



I have been trying to integrate webp to my site for a while now. I finally succeeded for the most part.  Server side, I put an httpd conf that serves webp whenever a browser accepts it and jpeg if not.  I also set up an inotify on all my images folders so that whenever a new image is uploaded, the jpg or png is also generated as a webp. It works wonderfully, even for images in modules, categories, manufacturers, suppliers, everything works except products images.

I suspect it is an htaccess issue, although as far as I can tell, the rewrite rules for products generated by TB does include webp.  However, if if I try to force serving webp, even in Chrome, the product images I get are only in jpeg.  Thanks to the inotify script, the webp do exists so I am at a loss as to why the webp is not served at all.

Edited by movieseals
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I don't know, but since nobody else has answered maybe this is better than nothing.

If you have an easy installer system, could you install a default Prestashop 1.7 or 1.6 or Thirtybees and try the module on that? Then get help from the module seller if it fails on the default? I guess that two sets of instructions on an .htaccess file is accident-prone, and to get the simplest set-up is good; maybe remove all your own code from .htaccess.

If you have large product photos compared to others on the site, could that be the problem? 

I notice that your site (seen from the UK) sometimes shows the moving icon like a washing machine that means a script is working slowly. I don't know if that's a clue; maybe there is something in the server set-up that makes scripts slow, and the server people could tell you.

If your module is hopeless, I had some luck with the one from Sunnytoo . It worked rather slowly, but got there in the end and didn't leave photo-not-found icons while working. I had to install the module and an over-ride, and then it just worked. Quality isn't great but that could be because I shrank the photos too much. I don't know if anyone knows the best webp module.

Nice site, by the way. I hope this helps more than it hinders because I have no clue what the problem is!

Edited by veganline
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...