Jump to content
thirty bees forum

TB 1.2 can't change product quantity


Recommended Posts


I recently updated to TB 1.2.0 and now when I add new products or try to change existing ones, I can't add or change the stock amount anymore. No matter what I enter it says it saved alright, but changes back to value from before (new products 0).

When I activated the debug mode I briefly got an error popup instead of the saved message that says: "parsererror: SytaxError: Unexpected token < in JSON at position 0"

The only suspicious entry in the phperror.log is the following:

PHP Notice:  Trying to access array offset on value of type bool in /www/htdocs/w01005b2/tb/classes/Product.php on line 7843

We're running on PHP 7.4.19 (already tried 7.3 with the same result). Advanced stock management is not activated.

Does anybody have an idea how this happened and how to resolve this? Core updater says all files are fine.


Edited by RabbitZzZ
add info
Link to comment
Share on other sites

On 7/1/2021 at 3:35 PM, RabbitZzZ said:

"parsererror: SytaxError: Unexpected token < in JSON at position 0"

One should fix such things. JavaScript has influence on what gets saved.

A typical reason for this kind of error is thirty bees sending back an (HTML) error page as answer to an Ajax request. To find out what's going on, open developer console and look at the raw response.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...