Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
verbatim7

Cache problem

Question

Hi!

First I would like to thank everyone involved in developing thirty bees. As many have already said, this is something that is very much welcome in the Prestashop community.

While playing with thirty bees i encountered a potential issue. After copying my store and migrating that copy to thirty bees, everything was working except caching (tested memcached - same config as on my production store - and redis). I am not sure why, but using the store (clicking around on the front) doesn't add anything to the Memcached or Redis server instances. I tested if the instances work by creating a small test script (using thirty bees code - required the config file and called Cache::getInstance()) to set and get an item to the cache and both Memcached and Redis saved and retrieved data from the cache. I am not sure what could be the issue and am open to all suggestions you guys have.

Things I have done: 1. Made sure everything in backend is set correctly 2. Tried deleting and adding the Memcached and Redis configurations multiple times 3. Tried on a clean migration, no extra modules or configuration changes

Thanks for the help!

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I havent tried using any other version than 1.0.3. Maybe it could work on previous version for some reason. I will give that a try later today and inform you about the results.

Share this post


Link to post
Share on other sites
  • 0

hi i change to cache to apc,file, redias,memcached, and all but the setting.inc.php define('PSCACHINGSYSTEM', 'CacheMemcache'); how to work this ? sorry may be my bad experience if need changes this file to same admin setted cache driver name?

Share this post


Link to post
Share on other sites
  • 0

That was the issue. I wasn’t aware that you removed the raw query caching. With full page cache enabled, the cache works flawlessly on both redis and memcached instances. Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...