Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Theo

[Solved][Please help] SEO Rewrite Problem: Trying to add manufacturer to Product route gives 404

Question

Hi

I'm trying to add the manufacturer to the Product route, like so:
{categories}{/:manufacturer:/}{rewrite}

The URL appears to be correct, and the product URL seems to reflect the new URL...
But I keep on getting 404...

What am I doing wrong here?

Your help is appreciated.

 

manufacturer url error.png

Edited by Theo

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0
6 minutes ago, piet said:

Maybe clear cache and renew .htaccess will help.

Thanks, I've done this - but no change... (New htaccess, Cleared TB cache, Browser cache = nadda )

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, datakick said:

Try this one:

{categories:/}{manufacturer:/}{rewrite}

Weird, I'm still getting 404... (cleared cache, generated new htaccess)
Am I missing a step? Is there a 're-index' I need to do somewhere?
Have you tried this on your local?

Share this post


Link to post
Share on other sites
  • 0

Works fine for me:

image.png.4d3a4d6692d5c0218ef172fca61c9393.png

However, I'm running on 1.1.x -- so maybe that's the difference. And, of course, if you modified routes for other pages, that can make a difference as well.

Share this post


Link to post
Share on other sites
  • 0
21 minutes ago, datakick said:

Works fine for me:

image.png.4d3a4d6692d5c0218ef172fca61c9393.png

However, I'm running on 1.1.x -- so maybe that's the difference. And, of course, if you modified routes for other pages, that can make a difference as well.

This is odd...
I'm running TB 1.1.0 and haven't made any other SEO Route changes...
If I use {tags} instead of manufacturer - it works. Weird.

But as soon as I use {manufacturer:/} it breaks... Even though the manufacturer exists and the path looks correct in the address bar.
Eeek...
 

Edited by Theo

Share this post


Link to post
Share on other sites
  • 0

I've checked this on a fresh install of TB 1.1.0 as well as an upgraded test install from 1.08 to 1.1.0
And I'm still getting this problem.... seems like it has something to do with {manufacturer:/}

Share this post


Link to post
Share on other sites
  • 0

Are you running your test on Windows or Linux? Maybe there is a difference in configuration.

 

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, piet said:

Are you running your test on Windows or Linux? Maybe there is a difference in configuration.

 

Windows on Xampp PHP 7.2. However, the URL seems to be correct and the other options {tags}, {reference} seem to work just fine...

Edited by Theo

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, datakick said:

what does your url look like?

it looks like this:
http://localhost/development/local-dev-sites/new-onlinecopiers/coffee-and-tea/tea/bee-hive/tea

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, datakick said:

try to apply this fix, hopefully it will solve the issue: https://github.com/thirtybees/thirtybees/commit/70f02721bc8ffae1e82c34a1b160ac3aee856cf8

Excellent! This is working, thank you 🙂

I assume that this patch is included in 30Bz Bleeding Edge (1.1.x+), hence the reason you didn't encounter it in your initial round of testing?

Edited by Theo

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Theo said:

Excellent! This is working, thank you 🙂

I assume that this patch is included in 30Bz Bleeding Edge (1.1.x+), hence the reason you didn't encounter it in your initial round of testing?

Yes, it's part of 1.1.x. But I found and fixed it only after you raised this issue. Thanks for that. 

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, datakick said:

Yes, it's part of 1.1.x. But I found and fixed it only after you raised this issue. Thanks for that. 

Ok cool, no problem 🙂

Thanks again for the patch 👍

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...